4

I tried to install media9 by putting the following code in the preamble:

\usepackage{media9,graphicx}

This in order to be able to add sound files to my pdf, as this guy also asked help about.

When compiling the pdf, I got several errors:

  • Support package l3kernel too old.
  • File ocgbase.sty not found.
  • You have requested, on input line 48, version 2016/03/26 of package expl3, but only version 2015/11/04 v6224 L3 programming layer (loader) is available.

I tried fixing this be reinstalling MikTex, by synchronizing MiKTeX package manager, and by running a MiKTeX update, but none seemed to work.

Thereupon I decided to delete

\usepackage{media9,graphicx}

from the preamble, but I still get the same error messages (including the one that I request something on line 48, which I don't) and cannot compile pdf's at all. What should I do to make the software know that I don't want to run/install l3kernel and ocgbase? I can't continue my work like this.

I use MiKTeX 2.9 and TeXstudio 2.10.8. This is my preamble now, although I can hardly imagine it to be of any help to anyone:

\documentclass[12pt,twoside]{report}
\usepackage[margin=2.5cm]{geometry}
\usepackage[natbibapa]{apacite}
\usepackage{graphicx}
\usepackage{subfig}
\usepackage[section]{placeins}
\usepackage{tipa} 
\usepackage{gb4e}
\usepackage{cgloss4e}
\usepackage{caption}
\captionsetup[table]{skip=0pt,font=footnotesize}
\captionsetup[figure]{skip=0pt,font=footnotesize}
\usepackage[T1]{fontenc}
\usepackage{multicol}
\usepackage{nomencl}
\usepackage{longtable}
\usepackage{tabularx}
\usepackage{array}
\usepackage{enumitem}
\setlistdepth{5}
\let\ipa\textipa
\let\cap\textsc
\usepackage{vowel}
\makeatletter
\renewcommand\paragraph{\@startsection{paragraph}{4}{\z@}%
{-2.5ex\@plus -1ex \@minus -.25ex}%
{1.25ex \@plus .25ex}%
{\normalfont\normalsize\bfseries}}
\makeatother
\setcounter{secnumdepth}{4} % how many sectioning levels to assign numbers to
\setcounter{tocdepth}{4}    % how many sectioning levels to show in ToC
\usepackage{wrapfig}
\newcommand{\BlankCell}{}
\let\eachwordone=\it
\usepackage{slashbox}
\usepackage{amssymb}

\newenvironment{dedication}
{\clearpage           % we want a new page
\thispagestyle{empty}% no header and footer
\vspace*{\stretch{1}}% some space at the top 
\itshape             % the text is in italics
\raggedleft          % flush to the right margin}
{\par % end the paragraph
\vspace{\stretch{3}} % space at bottom is three times that at the top
\clearpage           % finish off the page
}



\begin{document}
\section*{Acknowledgements}
In the preparatory phase,
\end{document}

If I open other .tex files and try to edit & compile those, I get te following error:

  • Could not start the command: "C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\xelatex.exe" -synctex=1 -interaction=nonstopmode "stories".tex
1
  • I notice that the "Support package l3kernel too old" error occurs as well if one is intended to use "sinuitx" package, after the latest updates. Mar 31, 2016 at 8:09

3 Answers 3

2

Thanks for the help. In my case I had to change the two dates in the xparse.sty and in the l3keys2e.sty from (2016/03/28) to (2016/03/26).

\RequirePackage{expl3}[2016/03/26]
\@ifpackagelater{expl3}{2016/03/26}

This is a quick solution for one or two installations, but not for more.

1
  • Changed the dates, still get the errors.
    – Eline
    Mar 31, 2016 at 11:58
1

I am not sure this solution is safe, but it works (tested on a Mac, with MacTex 2015, but it should apply to MikTeX as well).

Search for the xparse.sty file (on MacTeX it is in /usr/local/texlive/2015/texmf-dist/tex/latex/l3packages/xparse) and change lines 53 and 54 to:

\RequirePackage{expl3}[2016/03/26]
\@ifpackagelater{expl3}{2016/03/01}
1
1

The Miktex Packages have been updated now! A Simple update with both the Admin and the User tool should solve this Problem!

Some Users have downloaded packages with the User Package manager, if you do not use both it is possible that you do not update this package!

1
  • Probably better as a comment!
    – user30471
    Apr 11, 2016 at 8:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .