1

Here's my testcase:

\documentclass[12pt,english]{scrartcl}
\usepackage{titlesec}

\begin{document}
\section{Foo}
\end{document}

Using "pdfTeX 3.14159265-2.6-1.40.16 (TeX Live 2015)" and titlesec 2.10.1, this doesn't build:

! Missing number, treated as zero.
<to be read again>
                   }
l.5 \section{Foo}

It builds if I comment out the \usepackage line.

Both build fine in "pdfTeX using libpoppler 3.141592-1.40.3-2.2 (Web2C 7.5.6)" and titlesec 2.6.

What's going on?

  • titlesec 2.10.1 is buggy and has an update already since 2016/21/03, version 2.10.2 (and what @StevenB.Segletes noted about KOMA and titlesec ;-)) – user31729 Mar 30 '16 at 13:30
  • 1
    It works for me. But are you aware of the log warning? Class scrartcl Warning: Usage of package titlesec together with a KOMA-Script class is not recommended. I'd suggest to use the package only if you really need it, because it breaks several KOMA-Script features, i.e., option `headings' and the extended optional argument of the section commands. – Steven B. Segletes Mar 30 '16 at 13:30
  • @StevenB.Segletes: Indeed – Lightness Races in Orbit Mar 30 '16 at 13:32
  • See komascript.de/titlesec (German). The new titlesec version 2.10.2 does not work with KOMA version 3.19a. You have to install the prerelease of 3.20 from komascript.de/node/1801. But not that it is not recommended to use titlesec together wirh a KOMA-Script class. – esdd Mar 30 '16 at 13:39
  • 1
    @esdd: I suspect ultimately I'll stop using KOMA-Script and go back to article, but for now I'd just like to get my documents building again with a minimum of changes. :) I'm rebuilding my environment to pull down titlesec 2.10.2. Hopefully my KOMA isn't 3.19a. – Lightness Races in Orbit Mar 30 '16 at 13:41
1

This is broken in 2.10.2 too, but can be resolved by switching to the article class. Apparently this is one of those times that a compatibility warning ought to be heeded.

(I was unable to try it against the KOMA-Script 3.20 pre-release.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.