2

I have seen that a lot was already written on the error-message "destination with the same identifier (name{page.})". However in my case, no solution does the trick.

Here is a MWE that should replicate the mistake:

\documentclass[10pt,oneside,onehalfspacing]{book}

\usepackage[a4paper,margin=3cm]{geometry}
\usepackage{setspace}
\setlength{\parskip}{0.5em}

\usepackage{fancyhdr}
\pagestyle{fancy}

\usepackage{xcolor}

\usepackage{wasysym}
\usepackage{fixltx2e}

\usepackage[toc,page]{appendix}

\usepackage[natbibapa]{apacite}
\usepackage[nottoc]{tocbibind}

\usepackage{graphicx}
\usepackage[strings]{underscore}
\graphicspath{02\_images}

\usepackage[utf8]{inputenc}
\usepackage{csquotes}

\usepackage[plainpages=false,pageanchors=false,hidelinks]{hyperref}


\begin{document}

\chapter*{Declaration Of Authorship}
\pagenumbering{roman}
Some example...

\chapter*{Statement Concerning Publication}
Some example...

\chapter*{Acknowledgement}
Some example...

\pagenumbering{gobble}
\tableofcontents\thispagestyle{empty}

\chapter{Introduction}\label{Intro}
\pagenumbering{arabic}
Some example...

\chapter{Theoretical Framework}\label{TF}
Some example...

\chapter{Findings}\label{Fin}
Some example...

\chapter{Conclusion}\label{Con}
Some example...

\end{document}

I assume that the mistake comes from \hyperref but the follow solution does not do the trick:

\usepackage[plainpages=false,pageanchors=falsehidelinks]{hyperref}

The Pdf-File seems to be fine, but the error bothers me...

  • Try pageanchors=false as an option. The question is however, if the anchors are still correct, i.e. the linking leads to the correct position – user31729 Mar 30 '16 at 22:50
  • @ChristianHupfer, I already tried that option (sorry for not mentioning), does not solve the problem though. – Flavio Frei Mar 31 '16 at 8:33
  • @FlavioFrei: One error by me: It's pageanchor=false, not pageanchors, that fixes the problem for your MWE (at least), sorry about that. But fixltx2e is deprecated, since all features have been incorporated into the LaTeX core. – user31729 Mar 31 '16 at 9:13
  • @ChristianHupfer, that did the trick. I still don't unerstand why since I simultaneously resolved the issue with fixltx2e and did some other alterations, too. The mistake is gone though. – Flavio Frei Mar 31 '16 at 11:50
3

There were two things that I did to make the error go away:

  1. Remove fixltx2, since apparently the required code is now part of the LaTex core.
  2. Add pageanchor=falseto \hyperrefas an option.
  • 1
    pageanchor=false is certainly a way of shutting off all warnings about duplicate page anchors: this is because it suppresses generation of page anchors altogether (as its very name says!). But what if you do need such anchors in your document, for example, in order to have working links to pages in an Index? hyperref manual is not very clear about this, but I take the liberty to refer you to an answer I gave 20 days ago, in the hope that the experiments which I made and described there may give you some useful tip. – GuM Apr 2 '16 at 3:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.