I tried to compile a (flawlessly working) LaTeX document on a different computer, and suddenly was faced with the above error message printed by the xparse package (after that, many errors follow).

I'm working on both computers with miktex 2.9 (and Texnic-Center) on Windows 7 (64 bit).

I tried EVERYTHING I found on stackexchange or anywhere else on the web, including:

  • Updating all packages
  • Removing the l3 packages and reinstalling them
  • Doing the above for both the current user and in admin mode
  • Removing the complete miktex distribution and re-installing it
    • for only the current user
    • for "anyone who uses this computer"
    • with all packages
    • only the basic packages
  • Downloading the newest l3 packages manually from CTAN and copying them into the miktex folder
  • Refreshing the FNDB and updating formats afterwards

Nothing worked. Right now, I'm just out of ideas. ANY suggestions??

EDIT: After performing UlrikeFischer's suggestion, I get different errors. After a long compilation process, this is the log file I get:

Log File

  • 2
  • Okay, this is an EXTREMELY recent post I missed :-) But I actually tried even that before, and it didn't work... Mar 31 '16 at 10:27
  • 4
    The problem will be sorted out probably in a few hours, Christian Schenk already anounced the update. In the meantime get the l3kernel.tds.zip from CTAN (ctan.org/pkg/l3kernel, SVN 6468 (!!)), unpack it outside miktex, and add the root folder with miktex settings (user, not admin) as a new root. Mar 31 '16 at 10:29
  • @UlrikeFischer: Is there a way to know when the fixed update will be available? Because your suggestion does seem to work, but I have still some strange errors, and I'm not sure if they're related to the bug or not... Mar 31 '16 at 12:37
  • 2
    You are loading pstricks but compile with pdflatex. This can't work (and never did). The other error message (from xcolor) is a follow-up error. Mar 31 '16 at 14:37

I also encountered this problem after updating my MiKTeX installation today. A different question thread (https://tex.stackexchange.com/a/301738) provided a quick temporary work-around. For minimal example


Changing lines 53 and 54 in MikTeX installation directory/tex/latex/l3packages/xparse/xparse.sty to


Allows xelatex to compile the provided example.

  • Unfortunatelly, with plain pdflatex this did not work for me, and I can't use xelatex. Mar 31 '16 at 13:42
  • 1
    @lukas.coenig the fix is unrelated to xelatex/pdflatex and will work for either, perhaps you are getting the same error with a different package (eg xfrac) the same issue applies to all of them. But anyway a fix is already on ctan and will be in texlive/miktex as soon as possible. Mar 31 '16 at 14:12
  • Okay, great, I'll wait for it then! Thanks! Mar 31 '16 at 14:13

in TeX Live Utility find the update for l3kernel and install it. In Unix/Mac systems try: {tlmgr update l3kernel}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.