1

I'm aware this is a question concerning Mac OS X and TeX, but I guess people here already had similar issues.

MacTeX comes with TexShop. However, if I right klick a .tex-file, this editor doesn't show up in the "Open with" dialog. Do I really have to manually edit the .plist or something to get them associated under Mac? Every other editor works (eg. TeXmaker..).

closed as off-topic by user36296, Alan Munn, Mensch, Przemysław Scherwentke, Robert Dec 14 '17 at 1:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center." – user36296, Alan Munn, Mensch, Przemysław Scherwentke, Robert
If this question can be reworded to fit the rules in the help center, please edit the question.

  • rightclick -> goto Open With -> Other -> look for TeXshop in Applications-Folder -> check Set as default-box. You're done. – naphaneal Mar 31 '16 at 12:42
  • This sets the default for exactly this one file. I do not want that, neither do I want to set the default for all files of this type, which is on Cmd+I open with. Rather, I want TexShop to appear directly in the entries proposed after right click - "open with". – mike Mar 31 '16 at 18:05
  • In wich form woul I add something there? The folder is empty for me, so I have no idea how the entries should look like.. – mike Apr 1 '16 at 9:25
  • I revoked my last comment as it actually involves a little coding. so here's a possible solution to your problem utilizing Automator: discussions.apple.com/thread/2351508?start=0&tstart=0 – naphaneal Apr 1 '16 at 10:17
  • This question is probably better suited for apple.stackexchange.com – user36296 Dec 13 '17 at 22:20
1
  1. Open a finder window
  2. Right click on a .tex file and choose Get Info
  3. Select in open with the application you want to use to open .tex files
  4. Afterwards click change all to use this setting not only for this file but for all .tex files

Not the answer you're looking for? Browse other questions tagged or ask your own question.