I'm trying to compile a document with TikZ externalize and eps2pdf, both of which needs shell-escape to work. I'm using Emacs with AUCTeX, and would like to work from the editor alone. However, following various methods of enabling shell-escape still gives me the well-known

ERROR: Package tikz Error: Sorry, the system call 'pdflatex -halt-on-error -interaction=batchmode -jobname "Article-figure0" "\def\tikzexternalrealjob{Article}\input{Article}"' did NOT result in a usable output file 'Article-figure0' (expected one of .pdf:.jpg:.jpeg:.png:). Please verify that you have enabled system calls. For pdflatex, this is 'pdflatex -shell-escape'. Sometimes it is also named 'write 18' or something like that. Or maybe the command simply failed? Error messages can be found in 'Article-figure0.log'. If you continue now, I'll try to typeset the picture.

Everything works when I run pdflatex -shell-escape Article.tex from the command line. I have tested that shell-escape is truly enabled using


in my Tex-document, which consistently shows 1 when I have enabled shell-escape.

I run Windows 7 Enterprise, Emacs 24.4.1, TeXLive 2014

Does anyone have any suggestions as to where the problem could lie?



You must log in to answer this question.

Browse other questions tagged .