2

today i noticed that when i compile my Tex-File with LuaLaTeX and the Microtype-Package that the line-endings are not correctly formatted.

Here an small example where you can see that the punctuation marks and letters do not complete flush. They are partly moved. You can see this, by mark the text for example in Adobe Reader. There are the dots or commas or hyphens a little bit more to the right side of the document, since the other letters.

Here are the code:

\documentclass[
a4paper,
12pt,
DIV=calc,
oneside,
parskip=half
]
{scrreprt}

\usepackage{fontspec}
\setmainfont{Times New Roman}


\usepackage[a4paper, left=3cm, right=2.5cm, top=2.5cm, bottom=2.5cm, includefoot]{geometry}

\usepackage[tracking=alltext,letterspace=0]{microtype}
%\usepackage{microtype}
\usepackage{blindtext}

\begin{document}
\Blindtext
\end{document}

I fixed it temporarly with this command: \usepackage[tracking=alltext,letterspace=0]{microtype} instead of using \usepackage{microtype}. Is this a godd solution or is there a better solution or is the behaviour i noticed normal when using the Microtype-Package? I think not, because the words respectively the letters and punctuation marks should be flush straight to 100% or not?

  • 1
    You can disable character protrusion if you prefer. I don't recommend it as it should improve the result, which is the point as @barbarabeeton 's comment suggests. But you can switch features off selectively if for some reason you don't want those particular micro-typographic features. Or just not load microtype. – cfr Apr 1 '16 at 3:01
  • disabling it with \microtypesetup{protrusion=false} does it, too. thanks for the clarification of it. – Opa114 Apr 1 '16 at 10:55
4

What you're asking for is actually the point of microtype -- to make the right-side edge "optically" even, not leaving "holes" because of the open space above a period or hyphen; instead, it moves these just a bit into the margin.

the principle was explained in han the thanh's dissertation, and his tugboat paper specifically on microtypographic extensions.

that said, as pointed out in a comment, the feature can be disabled with

\microtypesetup{protrusion=false}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.