3

I recently installed TeX Live on OpenSuse 13.1 and all seems OK except that it installs stuff in /usr/share/texmf rather than /usr/local/share/texmf. However I now want to install the Mathtime Pro 2 (Lite) fonts and have downloaded the Lite package from PCTEX. I am using an install shell script written by James Fennell of NYU. James's script defaults to using /usr/local/share/texmf which is what kpathsea delivers for TEXMF on my SuSe system. The script then screws up because the TEX Live installation on my SuSe has set itself up in /usr/share/texmf. So I hard-coded TEXMF to be /usr/source/texmf and the re-install seems to be OK. In particular the mtpro2 directory gets created at /usr/share/texmf/tex/latex/mtpro2 , root owned and with mode 755. This directory contains mtpro2.sty and a few .fd files all root owned and with permissions set at 755 However, a final LATEX test example in the script falls over spectacularly when executing

\usepackage[lite,subscriptcorrection,slantedGreek,nofontinfo]{mtpro2}

followed a little later by:

! LaTeX Error: File `mtpro2.sty' not found.

Elsewhere in the install log we see:

-----------------------[ OUTPUT OF: updmap-sys --enable Map mtpro2.map ]-------------$
updmap is using the following updmap.cfg files (in precedence order):
  /etc/texmf/web2c/updmap.cfg
  /usr/share/texmf/web2c/updmap.cfg
updmap is using the following updmap.cfg file for writing changes:
  /etc/texmf/web2c/updmap.cfg
/etc/texmf/web2c/updmap.cfg unchanged.  Map files not recreated.
updmap: Updating ls-R files.
--------------------------------------------------------------------------------------$
Map mtpro2 present in updcfg file.

So what seems to be happening is that a Map command for mtpro2 is indeed present in the updcfg file but for some reason it's not getting executed properly and hence LATEX can't find mtpro2.sty when the test is run.

All help gratefully received.

  • 1
    Welcome to TeX.SX! Did you install from the texlive package provided by OpenSuSE? They are outdated by far most times. – user31729 Apr 1 '16 at 9:50
  • 2
    Don't install stuff manually into directories managed by your distro's package manager! Not just TeX stuff. Anything. In this case, get the value of TEXMFLOCAL from e.g. kpsewhich -var TEXMFLOCAL and install the files there. Then run mktexlsr followed by (probably) updmap-sys --enable <map file name>. It is better to do it another way on recent installations but OpenSuSE's is probably rather out-dated and this method should work. – cfr Apr 1 '16 at 10:54
  • You haven't installed fonts in your personal tree, so this isn't directly applicable, but the information in my question/answer on font installation may nonetheless be helpful. – cfr Apr 1 '16 at 10:56
  • Many thanks for this. You've certainly given me lots of things to try out and think about I'll let you know how I get on - DavidB – David Brailsford Apr 3 '16 at 10:41
1

Installing a commercial font for pdftex isn't easy, so one does not wish to repeat this task with every new installation of the OS. For many years I have been using my own TEXMFLOCAL tree for the fonts I purchased as time goes by.

For me the easiest way was to completely delete the openSuse version of TeX and replace it with the texlive-dummy, there is a package on CTAN for openSUSE. I install a vanilla texlive on a special partition on the harddisk, different from root and home partition. Every year I upgrade to the new version of texlive and administer it using the texlive manager (tlmgr). It just goes on using my TEXMFLOCAL tree, which is different from the TEXMFHOME tree.

I'm setting the pathes to the different trees in my ~/.profile file. After upgrading to the new version of texlive in June, all I have to do is to adapt the path (2015 => 2016, obviously), log out and in again, that's it. (You may know much more than I do about the way how to set up the environment of a user with files like .bash or .profile .)

If you are going to use LaTeX more than once, I advise you to change to texlive and repeat the installation of mtpro.

0

Thanks very much to Christian Hupfer, cfr and Keks Dose for some helpful comments/suggestions all leading in the same direction. The bottom line is to completely remove, using YasT,any existing Open Suse installation of texlive.

Then begin all over again with the canonical distro of texlive from tug.org at http://tug.org/texlive/quickinstall.html

Once this was installed and checked out as working I then managed to get James Fennell's shell script (at http://cims.nyu.edu/~fennell/mtpro2/ ) to work. This script is designed to install either the free (Lite) or the paid-for versions of the MathTime Pro fonts. James's script, at the moment, mostly gets the correct TEXMFLOCAL path from kpsewhich, but there is one place where it hard-codes an expected path to the install as being /usr/local/share/texmf (used on Mac and many linux installs?). Once this was replaced by a hard-coded /usr/local/texlive/texmf-local for the tug.org distro then everything seemed to install OK. So I can now set my documents in Times and my mathematics with MathTime (Times compatible) fonts. Thanks again everyone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.