1

I was compiling a TeX file with marvosym package - which was not installed in my computer. When it was automatically attempting to install the marvosym package, I force closed the program thinking that I will do it directly from the MikTeX package manager. But when I tried to get the package, the package manager showed that 'marvosym' was installed just now - during which I closed it forcefully.

Now, in my package manager, both install and uninstall options are greyed out and only properties option is active. I tried to manually delete all the files (by locating the files using the properties window) to reinstall the entire package. No luck - the install and uninstall options are still greyed out. I tried to run the .tex file again - this time it asked for installing the package, and I let it run completely - but I still have an issue where this package is not installed properly and therefore the pdf is not generated.

Is there any way to manually fix this issue - where I would be able to uninstall and install the package properly?

Thanks for your help!

  • 1
    Sorry, but why do think that is a good idea to stop a program in the middle of an installation? Beside this: as you don't say what is not working and which error you get, it is quite difficult to see which part of the package is missing. – Ulrike Fischer Apr 2 '16 at 19:04
  • try to rebuild FNDB and Update format in MiKTeX settings menu, then retry install routine for the package. And I agree with @UlrikeFischer. It's a bad idea to interrupt install procedures. – naphaneal Apr 2 '16 at 19:07
  • Sorry about that. The error is miktex-makemf: the umvs source file could not be found. Running ttf2pk.exe... :PK font umvs could not be created. Process exited with errors – Comfortably-numb Apr 2 '16 at 19:07
  • 1
    Sounds as if the map file has not been updated. Run on a command line updmap. – Ulrike Fischer Apr 2 '16 at 19:10
5

Sounds as if the map file has not been updated. Run on a command line updmap.

Remark: This is often necessary -- if you don't kill the installation -- as the admin package manager can not update user map files.

| improve this answer | |
0

Try running MiKTeX Package Manager (Admin) mpm_mfc_admin.exe instead of MiKTeX Package Manager mpm_mfc.exe.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.