0

I have taken this example from BibTex - Show ISBN number?:

\documentclass{article}

\usepackage[american]{babel}  %% added in a recent edit
\usepackage[backend=biber]{biblatex}

\usepackage{filecontents}

\begin{filecontents}{\jobname.bib}
@book{QueueSystems,
    author    = "Leonard Kleinrock",
    maintitle = "Queueing Systems",
    volume    = "1",     
    title     = "Theory",
    publisher = "Wiley-Interscience",
    year      = "1975",
    ISBN      = "0471491101",
}
\end{filecontents}

\addbibresource{\jobname.bib}

\nocite{*}

\begin{document}

\printbibliography

\end{document}

which works well as long as I do not specify the apa format. If I add the style=apa after backend=biber, it stops showing the ISBN entry. what should I do to make this example show the ISBN ? I tested adding \DeclareLanguageMapping{american}{american-apa} but to no avail. My installation of biblatex is very recent (version 3.3) and biber is version 2.4.

6
  • 1
    As per the package docs, add a babel line before loading biblatex - \usepackage[american]{babel}
    – PLK
    Apr 4 '16 at 21:32
  • True, adding \usepackage[american]{babel} allowed the document to compile. However, I still don't see the ISBN. Looking in the .bbl file, I do see the isbn fields \field{isbn}{0471491101}. So it does not completely answer the problem. Would it be possible that the apa format is outdated? the file american-apa.lbx is date 2016/03/01... Apr 5 '16 at 1:57
  • You have two unrelated problems here. The first one is the standard "you are missing \DeclareLanguageMapping" error, the second is that you don't get to see the ISBN. Since you are aware of the \DeclareLanguageMapping issue yourself, maybe you want to clean up your question to drop this, it is a red herring, but seems to have confused people trying to answer.
    – moewe
    Apr 5 '16 at 8:11
  • 3
    Showing ISBN is not part of APA style, that's why it's not implemented.
    – PLK
    Apr 5 '16 at 10:19
2

As far as I can see biblatex-apa just doesn't print the ISBN (from that I would infer that APA style does not require the inclusion of ISBNs - indeed, PLK confirms this in his comment). If you must have ISBNs you can modify the doi+eprint+url

\renewbibmacro*{doi+eprint+url}{%
  \printfield{isbn}%
  \newunit\newblock
  \iftoggle{bbx:doi}
    {\printfield{doi}%
     \iffieldundef{doi}{}{\renewcommand*{\finentrypunct}{\relax}}}
    {}%
  \newunit\newblock
  \iftoggle{bbx:eprint}
    {\usebibmacro{eprint}%
     \iffieldundef{eprint}{}{\renewcommand*{\finentrypunct}{\relax}}}
    {}%
  \newunit\newblock
  \iftoggle{bbx:url}
    {\usebibmacro{url+urldate}%
     \iffieldundef{url}{}{\renewcommand*{\finentrypunct}{\relax}}}
    {}}

With this change you could forfeit APA compliance, so make sure you really need to show the ISBN.

9
  • Thanks @moewe for setting the record straigth: APA indeed does not show ISBN. My mistake here. Thanks also for this answer and the note of caution: If one really wants to show ISBN, it shows how it can be done. Apr 6 '16 at 1:03
  • Note that currently (2021) the macro to change is doi+url, so without eprint. But the ISBN is still not part of the APA recommendations.
    – Marijn
    Mar 22 '21 at 12:54
  • @moewe: I'm also using APA style with biblatex and I would be interested in slightly customising the style. Specifically, I would like to have all non-empty fields in my .bib file printed. For journal articles that is already the case by default, but for books, proceedings, book collections, etc., I would also like to have ISBN, location, publisher, etc. fields printed, regardless of whether there is an available DOI or not. Which macros have to be modified so that those fields are not supressed and how precisely?
    – Euclides
    Nov 13 '21 at 19:15
  • @Euclides biblatex-apa implements APA style (as defined in the publication manual of the APA) as closely as possible with biblatex. It is not really intended for (large-scale and even smaller scale) modifications. If you want/need APA style, use biblatex-apa. If you don't want APA style, do yourself a favour and use a different base style (e.g. authoryear).
    – moewe
    Nov 14 '21 at 7:04
  • @moewe: I understand that, but I am not the only one not fully satisfied with the APA style. Even Elsevier modified it: for instance, they use location-publisher for books, etc. and dropped the journal article issue from their own APA style. As this would be for my PhD thesis and there are no strict guidelines at University level, I thought customisation would be OK for this case. Anyway if one can modify the doi+url bibmacro, there is certainly a way to modify the location+publisher bibmacro as well. I will try to find out..............
    – Euclides
    Nov 14 '21 at 8:03
0

I do not get an error. I am using latest Debian. I copied and pasted your code into Texstudio, and viewed pdf, showing the citation with ISBN number.

I added the style=apa so that:

\usepackage[backend=biber, style=apa]{biblatex}

and still no error.

4
  • Hum... I use MiKTeX version 2.9. Apr 5 '16 at 2:27
  • Are you sure you are still seeing the ISBN with style=apa? I have the current version (2016/03/01 v6.8) and don't get to see the ISBN.
    – moewe
    Apr 5 '16 at 8:10
  • Have rerun, still seeing the ISBN. Texstudio is 2,10,8 Biblatex is 3.3, dated March 8 2016
    – ozhank
    Apr 5 '16 at 10:36
  • What is your biblatex-apa version though? As I said I don't get the ISBN with style=apa and PLK (the developer) confirms this behaviour in his comments above.
    – moewe
    Apr 5 '16 at 12:15
0

The values are to be given within braces.

\documentclass{article}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{QS:1,
author    = {Leonard Kleinrock},
maintitle = {Queueing Systems},
volume    = {1}, 
title     = {Theory},
publisher = {Wiley-Interscience},
year      = {1975},
isbn     = {0471491101},
}
\end{filecontents}
\usepackage[backend=bibtex,sorting=none]{biblatex}
\addbibresource{\jobname.bib}
\begin{document}
\nocite{*}
\printbibliography
\end{document}

bibi

1
  • 1
    Although I do prefer to wrap fields in braces and not in quotation marks you will find that you example still works if you use " instead of {...}. The issue here is the biblatex-apa style and not the field delimiters. " and {...} are largely equivalent ...
    – moewe
    Apr 5 '16 at 8:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.