0

One of my frustrations with TXS is when I use the package glossaries, for example, it autocompletes properly to \acrfull but not \ac. I dug through the code in the .dtx file and found that \ac is defined as

\let\ac\gls

TeXStudio also highlights the command, e.g. \ac{hello} as invalid. When I compile the document it renders out just fine.

Is this a bug?

Note: I tried updating the .cwl file and restarted TXS, but it still didn't autocomplete or show as a valid command.

  • usually a restart of TXS does fix it. have you tried that? – naphaneal Apr 6 '16 at 21:05
  • Updated question. @naphaneal I've used TXS for months now, and it's always been that way, no matter how many times I restart the program. – tralston Apr 6 '16 at 21:08
1

Autocompletion and knowledge on commands in the editor is gained from cwl files. The definiton of \ac was just in glossaries.cwl. I've just fixed this, so it will be available with the next release of TXS.

For now, you cannot do anything about this yourself, because the builtin cwl files cannot be overridden. This will be changed as well in the next release (> 2.10.8).

For more details see FAQ: What are cwl files good for and how do they work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.