6

I am in trouble. I would like to organise index by texindy for slovenian language, but reactions are highly unstable.

If I use …

\usepackage[texindy]{imakeidx}
    \makeindex[intoc, columns=2, options= -s z.ind]{\fontsize{9pt}{2pt}\printindex} 

z.ind= 
(headings_flag 1 
heading_prefix "\n %\\normal %\\fontec \\noindent \\textbf{"heading_suffix "} %\\par \\nopagebreak \n")

enter image description here

Two days ago, all was OK, but now all is false again. Nothing happened, even if I recompile many times. All Slovenian special characters (ČŠŽĆ) go under the Symbols. I can’t find some correct and stable solution over the internet.

Does anybody have any idea how to deal with index for Slovenian? ... except my apologies in footnotes?

3

You have to pass Xindy the language you're going to need for collation of the particular index.

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[slovene]{babel}

\usepackage{imakeidx}

\makeindex[program=texindy,options=-L slovenian -C utf8]

\begin{document}

A\index{Altamira}

B\index{Babbage}

Č\index{Čeh}

Ž\index{Žvanut}

\printindex

\end{document}

enter image description here

| improve this answer | |
  • Egreg, Thanks a lot :-) it work well, Miran – user102582 Apr 7 '16 at 15:43
  • @user102582 You owe me a drink when I'll come to Slovenia, favorite destination for my Saturday bike tours. ;-) – egreg Apr 7 '16 at 16:28
  • so you are somwhere near? Absolutely :-) – user102582 Apr 8 '16 at 13:20
  • @user102582 If you have time, you can join us in the chat: chat.stackexchange.com/rooms/41/tex-latex-and-friends – egreg Apr 8 '16 at 13:38
1

Try to look at russian index

It works great for russian index, I've checked. I guess slovenian index will be ok too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.