4

I'm using TeXstudio 2.10.8 (that was compiled with Qt 5.2.1 R), running on Ubuntu 14.04.


Issue: Some default shortcuts of TXS (e.g. Ctrl+C, F6, etc.) are working, when some others (Ctrl+E, F8, etc.) don't. How to fix this?

I have found two related tickets in the sourceForge repo (#1467 Shortcuts does not work after upgrade to 2.10 and #1495 Keyboard shortcut for segment preview doesn't work ). However, the suggested solution is to wait for a newer (relative to the date of the post) release (that is TXS 2.10.4) since there was a bug due to Qt 5.5. But the version I'm using (2.10.8) is newer (and the most up-to-date public release as far as I can tell)...

closed as off-topic by Torbjørn T., moewe, Mensch, user13907, Joseph Wright Apr 7 '16 at 9:34

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    I'm not really sure if there's anything we can do here, it sounds like a bug. (Bug reports are also generally considered off-topic.) Have you reported it at SourceForge? – Torbjørn T. Apr 7 '16 at 8:17
  • @TorbjørnT. you're right, I think it's a bug report. Should I then delete my question? (I've just posted a ticket on SourceForge.) – ebosi Apr 7 '16 at 8:20
  • Either that, or you can add a link to the bug report and we can close the question. – Torbjørn T. Apr 7 '16 at 8:27
  • 4
    I'm voting to close this question as off-topic because it is a bug report (reported at sourceforge.net/p/texstudio/bugs/1732). – Torbjørn T. Apr 7 '16 at 8:33
7

As explained on TXS webpage:

For Ubuntu 14.04 use Qt4 Version.

Thus, I stored my personnal settings (own shortcuts, etc.) stored in ~/.config/texstudio/texstudio.ini and made a fresh install using the right version.

sudo apt-get remove texstudio
sudo apt-get install texstudio-qt4
  • 1
    I had the same problem - non-working shortcuts - in Ubuntu 16.04. I switched to the Qt4 version, and now the shortcuts are working, but there are other problems - the tools in the toolbar are invisible (I can click them, but I do not see them). – Erel Segal-Halevi Aug 3 '16 at 18:51
  • 1
    Henry's comment here: tex.stackexchange.com/questions/185760/… solved the problem: close TXS, run sudo apt-get install libqt4-svg and restart. – Erel Segal-Halevi Aug 3 '16 at 18:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.