1

I just switched to a new laptop and am having trouble getting a few packages to work on the new machine. I installed Miktex 2.9 basic package and the style files I need to access are contained in the cite and fancyhdr packages. Now, I can of course put the stlye files in the directory with my main .tex file, but this is not the point. I am trying to properly install these two packages, but cannot get Latex to find them

kpsewhich -var-value=TEXMF returns four folders (two user specific folders and two System folders), one of which is C:\Program Files\MikTex 2.9. The issue is that I have placed the cite package, for example, at C:\Program Files\MikTex 2.9\tex\latex\cite, but I still get the installation prompt saying The required file tex\latex\cite\overcite.sty is missing. The same thing happens with fancyhdr.sty if I place that package in the same place.

Why can't my compiler find the package? I am looking right at it as far as I know.

  • 1
    After putting the new style files in the texmf tree, did you refresh MikTeX's filename database? See here docs.miktex.org/2.9/manual/configuring.html – rbrignall Apr 7 '16 at 20:42
  • 2
    You do not have to place the packages by hand: use MiKTeX Package Manager to install new packages. – Bernard Apr 7 '16 at 20:55
1

Looks like you have everything in the correct place but you need to refresh the File Name Database for MikTex to find it.

Go MikTex Settings (Admin) from your start menu (or equivalent) → click Refresh FNDB.

This will refresh the database letting MikTex know the locations of the packages.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.