1

I installed a TrueType font in windows 10. Now I want to use it with XeLaTeX. The font can't be loaded. The first message is

Sorry, but miktex-makemf did not succeed for the following rea

son: The DIN source file could not be found. The log file hopefully contains the information to get MiKTeX going again: C:/Users/user/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makemf.log You may want to visit the MiKTeX project page, if

you need help.

hbf2gf (CJK ver. 4.8.4) Couldn't find `DIN 67.cfg'

The first error message is

fontspec error: "font-not-found" The font "DIN 6776" cannot be found. For immediate help type H <return>. \setmainfont{DIN 6776}

I can use this font in Office with this name. So I tried to use the font with LuaLaTeX and it worked. I tried to load the font by filename and worked with XeLaTeX and LuaLaTeX. This is a workaround but no solution. Other system fonts can be loaded as expected without problems. What is the problem with this font? What did I forget?

1
1

I opened the font with FontForge and generated a new TTF. Now everything works as it should. So something is wrong with some of the font names or with the file structure that LuaLaTeX can handle but XeLaTeX can't. I tried other fonts from the source (ufonts.com) and DIN 6776 was the only font with this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.