1

According to my institute guidelines Ii have to do the following in my thesis:

  • Left margin: 1.25" (to ensure sufficient space for binding), Right mar- gin: 1"
  • Caution: For front and back printing, left and right depends on the page number being odd or even. Therefore for the thesis which is to be printed back and front, the margins of odd numbered pages (=pages on right) are as above, while for the even numbered pages (=pages on left) the left margin should be 1" and right margin should be 1.25".

I used this in my preamble:

\documentclass[12pt]{report}
\usepackage{epsfig,epic,eepic,units}
\usepackage[inner=1.25cm,outer=1cm,bottom=2cm, top=2cm]{geometry}

But this is keeping 1.25" space on left on even number pages too. How can I keep odd number pages at 1.25" on left and 1" on right but vica versa for even numbered pages?

  • Set the left and right margin to 1inch and use the option bindingoffset=0,25in – Sveinung Apr 8 '16 at 7:34
  • Add option showframe to the call of geometry to better see what left and right hand pages are. – Johannes_B Apr 8 '16 at 7:37
  • Without a minimal working example, we cannot varify that your document is faulty and rely on you stating it. Not a good way to propose a solution. – Johannes_B Apr 8 '16 at 7:37
  • I looked at your other questions, TeXmaker and overleaf are just editors and have nothing to do with any error messages LaTeX gives you. – Johannes_B Apr 8 '16 at 7:48
  • 3
    You should add the twoside option to the \documentclass command: the report class uses oneside by default. You should better do so even if your margins were symmetric. – GuM Apr 8 '16 at 7:51
2

You should use the following setup:

\documentclass[twoside, <further options>]{report}
\usepackage[inner=1.25in, outer=1in, vmargin=2in]{geometry}

where <further options> might include 12pt.

Note that whereas the instructions appear to be phrased as using inches as the main unit of length, your code appears to be using centimeters as the unit of length. Do clarify with your school which length unit applies.

  • I want inches... How do I change that? – Bhaskar Vashishth Apr 8 '16 at 9:30
  • @BhaskarVashishth - Please look at the code in my answer: it uses in rather than cm as the unit of length. Doe this answer your question? – Mico Apr 8 '16 at 9:36
  • I ll let you know once I ll run this. Thanks. – Bhaskar Vashishth Apr 8 '16 at 9:44
  • it works but what is the purpose of \vmargin can you tell? – Bhaskar Vashishth Apr 8 '16 at 11:57
  • @BhaskarVashishth - vmargin=2in is more concise than bottom=2in,top=2in. – Mico Apr 8 '16 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.