I wish to typeset some relatively long URLs in a piece of text, and when I use \url{..}, the resulting text does not respect the margin boundaries that govern the main text body, instead going all the way to the edge of the paper before wrapping around.

For reference, my preamble looks like this:

\documentclass[12pt]{article}
\usepackage{mathptmx}
\usepackage{fullpage}
\usepackage[pdftex]{hyperref}

and example of the url I'm including is:

\begin{itemize}
\item Some text

\url{very-long-url}
...
\end{itemize}

I'm compiling using pdflatex, although I doubt this makes a difference.

  • 11
    Alas, a quick google search found my answer (use the [hyphens] option to the url package). Not sure if I should leave the question up here for future reference or just delete it. – Suresh Sep 13 '10 at 4:01
  • 6
    It seems like a reasonable question. You should make your comment an answer. Wait a bit, if no one else has a good answer, just accept your own comment. I think there's even a badge for it. – TH. Sep 13 '10 at 5:01
  • You could also perhaps consider a service such as tinyurl to shorten it. Long urls are plain ugly in a publication. – Yiannis Lazarides Sep 13 '10 at 14:30
  • 9
    ... but URL shortening (a) makes the destination opaque and (b) adds another indirection layer vulnerable to linkrot. – Reid Sep 16 '13 at 20:09
  • 1
    The problem with all the answers, I think, provided to this question is that (when a certain URL is broken across multiple lines) every PDF viewer which I tried will only highlight that line of the URL which one is clicking on (and not the complete URL), which is confusing. Anybody knows how to fix it? – Vincent Mia Edie Verheyen Apr 16 '16 at 22:12

15 Answers 15

up vote 154 down vote accepted

(converting a previous comment to an answer)

A quick google search (alas, too quick) reveals one solution. Use the [hyphens] option with the url package:

\PassOptionsToPackage{hyphens}{url}\usepackage{hyperref}

Some recommendations also include inserting \sloppy in case latex is trying too hard to align things.

  • 26
    actually it would be \usepackage[hyphens]{url} – Suresh Oct 31 '10 at 6:48
  • 57
    @xport: hyperref loads the url package internally. Use \PassOptionsToPackage{hyphens}{url}\usepackage{hyperref} to pass the option to the url package when it is loaded by hyperref. This avoids any package option clashes. – Martin Scharrer Jul 12 '11 at 11:26
  • 5
    @Suresh A minimal usage-example with some blind text would be nice. – Martin Thoma Sep 20 '12 at 4:51
  • 11
    If the \PassOptionsToPackage{hyphens}{url} approach does not work, maybe it's "because you're trying to load the url package with a specific option, but it's being loaded by one of your packages before that with a different set of options. Try loading the url package earlier than the package that requires it. If it's loaded by the document class, try using \RequirePackage[hyphens]{url} before the document class." latex-community.org/forum/viewtopic.php?f=5&t=22526#p76347 – Alessandro Cuttin Mar 23 '15 at 16:37
  • 5
    I have just experienced the issue too. On my side, \PassOptionsToPackage{hyphens}{url} was not working because of BibLaTeX, I had to write that command and load hyperref BEFORE BibLaTeX was loaded, which solved the problem. Gonna edit the answer. – wget Apr 9 '15 at 8:54

The package url defines a command \def\UrlOrds{\do\*\do\-\do\~\do\'\do\"\do\-}% which can be added to the default url break characters at which a line can be broken. Below, the line \g@addto@macro appends the list of characters defined in \UrlOrds to the \UrlBreaks macro.

\documentclass{article}
\textwidth=8cm
\parindent=0pt

\usepackage{url}
\makeatletter
\g@addto@macro{\UrlBreaks}{\UrlOrds}
\makeatother
\begin{document}
\rule{\linewidth}{1pt}

foo bar baz \url{very-long-url-very-long-url-very-long-url-very-long-url-very-long-url-}

\end{document}

enter image description here

The same effect could be obtained by using the more usual \renewcommand on \UrlBreaks, but this would remove the characters that were already defined in \UrlBreaks.

  • 11
    a few explaining words might have been nice in this answer... – xubuntix Nov 1 '12 at 10:15
  • 2
    woohoo! This is the only one that worked for me. The other similar answer by @xamde blew TeX's capacity. – Joe Corneli May 22 '13 at 13:28
  • tested and worked! – Jus12 Sep 8 '14 at 6:05
  • The only working method for me also. – Loi.Luu Sep 17 '14 at 11:36
  • Thanks! Works in combination with sloppypar wonderfully! – gilu Feb 5 '16 at 7:58

I carefully read the documentation of the url package (I'm using PDFLaTeX) and found the following to work quite nice to let LaTeX add line breaks after every normal alphabetic character:

\expandafter\def\expandafter\UrlBreaks\expandafter{\UrlBreaks%  save the current one
  \do\a\do\b\do\c\do\d\do\e\do\f\do\g\do\h\do\i\do\j%
  \do\k\do\l\do\m\do\n\do\o\do\p\do\q\do\r\do\s\do\t%
  \do\u\do\v\do\w\do\x\do\y\do\z\do\A\do\B\do\C\do\D%
  \do\E\do\F\do\G\do\H\do\I\do\J\do\K\do\L\do\M\do\N%
  \do\O\do\P\do\Q\do\R\do\S\do\T\do\U\do\V\do\W\do\X%
  \do\Y\do\Z}
  • 4
    None of the previous (higer-rated) suggestions worked for me with a troublesome URL I was dealing with. This option did work. Are there any potential problems with this approach? All I see is that it may not always break at a "visually appealing" part of a URL. – SSilk Jun 25 '12 at 13:19
  • 6
    This is a bad solution, because it removes all characters predefined within \UrlBreaksin the package. This can mislead other users, see e.g. Dots are smaller when UrlBreaks defined. – Speravir Feb 25 '13 at 17:51
  • 6
    @Speravir would you mind to edit/delete your comment as the problem and the resulting question were fixed ({\UrlBreaks% save the current one) and it scares users off with its many upvotes? – jan-glx Aug 26 '16 at 8:48
  • 1
    This solution seems to work better than the others, but I experienced a problem in the limit case when the url ends close to line ending; LaTeX is unable to put the word following the url to a new line and puts such word (or at least the first syllable of it) in the same line, even if it protrudes from right justification, with really bad results. – mmj Nov 28 '16 at 11:27
  • 2
    I had to cite the following link in a bibliography. ons.gov.uk/economy/nationalaccounts/uksectoraccounts/datasets/… This answer was the only solution. – Hugh Dec 5 '16 at 12:35

Using the sloppypar environment as in

\begin{sloppypar}
  Figure \ref{fig:example_instant_lumi}:
  Public result available from \url{https://twiki.cern.ch/twiki/bin/view/AtlasPublic/LuminosityPublicResults}, version of 16.12.2011.
\end{sloppypar}

helps in my case. Without sloppypar the AtlasPublic part runs over the right margin, with sloppypar LaTeX breaks after view/ and everything's fine. (Doesn't need the url package.)

  • 2
    This worked beautifully for me! Thanks! – thedoctar Jul 29 '12 at 15:41
  • I found that sloppypar and the url package worked well together. – Faheem Mitha Sep 22 '13 at 18:44
  • I have combined the suggestion by @Herbert and yours, and it looks like this method works for me. But I found one "full stop" notation below the reference entry. Is there any way to eliminate that? Thank you. – Vijay Sep 22 '14 at 5:47
  • This also works with biber. \begin{sloppypar} \printbibliography \end{sloppypar} – koppor Feb 2 '17 at 8:17

Herbert Voß has just created (December 2017) the package xurl.

This package allows urls to break everywhere, can be compiled simply with pdflatex, and has the same options as url (indeed, it loads url package).

Here an MWE:

% arara: pdflatex
\documentclass{article}
\parindent=0pt

\usepackage{xurl}

\begin{document}
\rule{\linewidth}{1pt}

An example of everywhere breaking url: 
\url{very-long-url-very-long-url-very-long-url-very-long-url-very-long-url}

Another example of everywhere breaking url: 
\url{very-long-url-very-long-url-very-long-url-very-long-url-very-long-url}

A third example: 
\url{very-long-url-very-long-url-very-long-url-very-long-url-very-long-url}

\end{document}

Here the output:

enter image description here

  • 2
    This is the best answer in my opinion – Julio Jun 9 at 11:40
  • 1
    @Julio Thank you, my answer is recent, there wasn't this package at the time of the other answers... – CarLaTeX Jun 9 at 11:47
  • 3
    This is not just the best, it's the only solution that works perfectly for me as of June 2018. – mmj Jun 26 at 20:22
  • @mmj Thank you, we should thank Herbert Voß, first of all! – CarLaTeX Jun 26 at 23:45

If it's not necessary for the url to appear verbatim, you could use \href{url}{text}. That way you could give the url a human-readable form. If your document is used electronically you just use it as an hyperlink and if the document is printed you could (or should) question the relevance of long (and probably cryptic) url's.

  • 5
    URLs often appear in bibliographies. For an online resource, they should not be omitted. – TH. Sep 13 '10 at 10:02
  • I could have reformatted the text as a bibliography, but in my particular setting this would have been too clunky. – Suresh Sep 14 '10 at 7:17
  • 1
    For some ungainly long URLs one can set up URL-shortened links via tinyurl.com, bit.ly, or other similar sites. Then the printed link can be the readable short link but the underlying link in the PDF can go to the original URL. – András Salamon Sep 26 '10 at 15:59
  • 5
    You can also use \href with the text set to the url, using \texttt, and putting the line breaks in explicitly. You gain flexibility at the price of a little more work. – Tom Zych Sep 15 '12 at 0:00
  • 1
    Instead of \texttt with manual line breaks, you can use the \path command from the url package, as mentioned in this question. This is the only way I was able to get sensible display of URLs in a bibliography on the arXiv. – Mike Shulman Jul 23 '13 at 21:14
  1. \usepackage[hyphens]{url} should be ok. If it does not work, then go to (2).

  2. \RequirePackage[hyphens]{url} before \documentclass.

  3. \expandafter\def\expandafter\UrlBreaks\expandafter{\UrlBreaks% save the current one \do\a\do\b\do\c\do\d\do\e\do\f\do\g\do\h\do\i\do\j% \do\k\do\l\do\m\do\n\do\o\do\p\do\q\do\r\do\s\do\t% \do\u\do\v\do\w\do\x\do\y\do\z\do\A\do\B\do\C\do\D% \do\E\do\F\do\G\do\H\do\I\do\J\do\K\do\L\do\M\do\N% \do\O\do\P\do\Q\do\R\do\S\do\T\do\U\do\V\do\W\do\X% \do\Y\do\Z}

    It does work, but it is not a good way because it breaks the url address at an arbitrary place, which looks ugly.

  4. \sloppy sometimes does work, sometimes does not. It is not a thorough solution.

I recommend Solution (1) or (2).

  • 1
    \soppy should be used iin a group only. – Johannes_B Oct 8 '15 at 9:10
  • 3
    I feel this is more or less a mash-up of other answer already given, can you explain what your approach adds to the answers present. – moewe Oct 8 '15 at 9:30
  • 1
    @moewe I have surveyed and summarized the answers above. – STUDY Oct 8 '15 at 10:31
  • 4
    I think you can show your approval or disapproval of certain solutions by voting and commenting, so those summary answers are of no real use. But then again, some people may like those summary answers. I just wanted to point out that these answers are really unusual here. – moewe Oct 8 '15 at 15:20
  • 1
    @moewe Yes, you are right. But the only problem is that I have no enough reputations to comment others' answers. – STUDY Oct 9 '15 at 6:17

You may also want to look at the breakurl package.

  • 20
    this is a package for latex->dvips->ps2pdf and not for pdflatex – Herbert Feb 6 '11 at 20:33

Not using \url, but \href, the URL is not visible anyway, so the suggestion in regard to employing tinyurl is relevant as it does avoid the ugliness of the URL in the text.

Much better, I find, to make an appropriate part of the text active, as in \href{URL}{active in context text}.

This way, the URL is not visible in the print out either.

According to the documenation, BigBreaks is the way to go otherwise it breaks at the first character.

\def\UrlBigBreaks{\do\/\do-\do:}

See: http://texdoc.net/texmf-dist/doc/latex/url/url.pdf I had the problem that a line break was inserted always after http:, even when using \UrlBreaks, the documentation clarified that this is the intended behavior.

I have a similar problem with itemize environment. When a word (or an url) is too long to respect the margin it does not starts a newline. Using \sloppy works but is very ugly.

My LaTeX code is generated by rst2latex.py and I use pdflatex on it.

I found that much better solution on the latex-community.org forum :

\tolerance 1414
\hbadness 1414
\emergencystretch 1.5em
\hfuzz 0.3pt
\widowpenalty=10000
\vfuzz \hfuzz
\raggedbottom

So I add this snippet in my docutils.tex and everything is just fine !

  • 1
    I think it is ok to post this here, but please have a look, if this works for the original problem too. – bodo Sep 14 '12 at 11:59
  • I have checked with urls and it works. I can't remember why I was talking about the abstract context, maybe my brain was still in another post. – Stan Sep 14 '12 at 15:39

I troubles I had with url breaking in an itemize environment could be solved by adding \Urlmuskip = 0mu plus 1mu in the preamble.

  • 1
    Welcome to TeX.SX! You can have a look on our starter guide to familiarize yourself further with our format. – mafp Jun 19 '13 at 8:02

The solution that works perfect for me both for bibtex and biblatex is the combination of sloppypar that @fuenfundachtzig mentioned with the \usepackage[hyphens]{url} that proposed by @Suresh.

The next code is used to be able to use both ways (bibtex and biblatex) to compile your file and works for me in cases of natbibs agsm style and bibers authoryear. Actually you don't have to use both ways and the method will work (I think) anyway if you just keep the code of each case (bibtex or biblatex) [except of the trick of @moewe with the url that solved the problem I had in my post here that will be possibly need to be adjusted according to the bibtex style we will use].

\documentclass{article}
\usepackage{filecontents}
% \UseBibLaTex is a variable that if is less than 1 the document 
% will have to compiled with `bibTeX`... else with biber
\def\UseBibLaTeX{1}
% ``url'' package is used in order to make LaTeX to break the urls 
% in places like the bibliography combined with the next (upcoming) 
% command
%\usepackage{breakurl}
\usepackage[hyphens]{url}
\Urlmuskip=0mu plus 1mu minus 5mu


\ifnum\UseBibLaTeX>0
\usepackage[backend=biber,style=authoryear]{biblatex}
\addbibresource{myBib.bib}
\else
\usepackage{natbib}
\def\harvardurl#1{{\bfseries URL:}\space\url{#1}}
\fi


\begin{filecontents*}{myBib.bib}
@Article{cite1,
title={One Article with a url that has to break both in bibtex and biblatex},
author={Someone NotMe and Someother Me},
year={2018},
month={10},
url={http://A-long-URL-that-has-to-break-through-lines-and-biber-has-to-ignore-the-url-command},
doi={http://dx.doi.org/10.1038/nphys1170}
}
@Article{cite2,
title={One Article with another url that has to break both in bibtex and biblatex},
author={Someone NotMe and Myself Me},
year={2017},
month={10},
url={http://AlongUrlThatHasToBreak.ThroughlinesAndBoth.BiberAndBiblatex.HasToAcceptTheCitation.com},
doi={http://dx.doi.org/10.1038/nphys1170}
}
\end{filecontents*}

\title{Double Functionality about Bibliography}
\author{Konstantinos Leledakis}
\date{October 2018}

\begin{document}

\maketitle

\nocite{*}
\ifnum\UseBibLaTeX>0
\begin{sloppypar}
\printbibliography
\end{sloppypar}
\else
\bibliographystyle{agsm}
\begin{sloppypar}
  \bibliography{myBib}
\end{sloppypar}
\fi

\end{document}

Output with bibtex:

enter image description here

Output with biblatex (biber):

enter image description here

I used the .bib file with these packages.

\usepackage{breakurl}
\usepackage{url}

And that made the work.

I would like to link to the following question here on TeX-SE: https://tex.stackexchange.com/a/207712/128658

Followed by \Urlmuskip=0mu plus 1mu\relax this does result in URLs that are properly broken over multiple lines without causing any overfull boxes. Plus this does also work for URLs in bibliographys (opposed to @xamde's answer to this question).

If you are doing this sorcery inside a package instead of your actual document you have to encapsulate the counter-changes in a \AtBeginDocument as they aren't defined otherwise. It could therefore look something like this:

% set special behaviour for hyperlinks in pdfs
\RequirePackage[breaklinks=true, pdfencoding=auto]{hyperref}
\g@addto@macro\UrlBreaks
{%
    \do\a\do\b\do\c\do\d\do\e\do\f\do\g\do\h\do\i\do\j%
    \do\k\do\l\do\m\do\n\do\o\do\p\do\q\do\r\do\s\do\t%
    \do\u\do\v\do\w\do\x\do\y\do\z\do\&\do\1\do\2\do\3%
    \do\4\do\5\do\6\do\7\do\8\do\9\do\0\do\/\do\.%
}
\g@addto@macro\UrlSpecials
{%
    \do\/{\mbox{\UrlFont/}\hskip 0pt plus 10pt}%
}

\Urlmuskip=0mu plus 1mu\relax

\AtBeginDocument{%
    \setcounter{biburlucpenalty}{1}  %break URL after uppercase character
    \setcounter{biburlnumpenalty}{1} %break URL after number
    \setcounter{biburllcpenalty}{1}  %break URL after lowercase character
} 

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.