1

Is it just me or do the pdfpages not get included when using the texcoord option for eso-pic. Could someone confirm this. This is the MWE:

\documentclass[12pt,a4paper,notitlepage,oneside]{book}
%NOTE Packages, my Macros und Formatdefinitions
    \usepackage[T1]{fontenc}            % Allows different font encodings and hyphenation -> ctan.org/pkg/fontenc
    \usepackage[utf8]{inputenc}         % Translates input encodings into LaTeX internal language -> ctan.org/pkg/inputenc
    \usepackage[texcoord=true,colorgrid]{eso-pic}   % Command for absolute picture/grid/watermark postioning-> ctan.org/pkg/eso-pic?lang=en
    \usepackage{pdfpages}

\begin{document}
\section{hi}
Option pscoord does work, but texcoord option of eso-pic causes blank pages
\includepdf[pages=-]{./prelims/myprelims.pdf}
\end{document}

I do get an option clash when including eso-pic options after pdfpages. I would like to have the grid on with origin on the upper lift while including pdfpages, thats the plan.

  • Not on a pc so cannot test, but doesn't pdfpages also use eso-pic so any options that change how eso-pic would also affect pdfpages – daleif Apr 10 '16 at 18:15
  • Yes, it does need eso-pic, everyshi and some std-pkgs, do I have to explicitly include them or is it ok to have them installed. (All uptodate here using texlive) – qrtLs Apr 10 '16 at 18:21
  • 1
    It is done automatically. What I'm saying is that the options you give to eso-pic may inadvertently affect pdfpages is a bad way. I've never used any of those eso-pic option and cannot test until tomorrow – daleif Apr 10 '16 at 18:30
  • 1
    I would guess your plan is the problem here. Presumably pdfpages assumes the coordinate system starts in the lower left hand corner. When you switch it to the upper left hand corner, all the pages are included above the visible area. – daleif Apr 10 '16 at 18:33
  • 1
    @daleif I meant "you could try the package pagegrid instead". – Ulrike Fischer Apr 11 '16 at 7:18
2

The pdfpages package assumes that the coordinate system always start in the lower left hand corner. So when texcoord=true is active and the coordinate system now starts at the upper left hand corner, the included pages are included at coordinates above the visible area of the current page.

Solution: don't use texcoord=true

As Ulrike mentioned one could use pagegrid, which does not interfere with pdfpages and the eso-pic options:

\documentclass[12pt,a4paper,notitlepage,oneside]{book}     
\usepackage[T1]{fontenc}            % Allows different font encodings and hyphenation -> ctan.org/pkg/fontenc
    \usepackage[utf8]{inputenc}         % Translates input encodings into LaTeX internal language -> ctan.org/pkg/inputenc
    \usepackage{eso-pic}    % Command for absolute picture/grid/watermark postioning-> ctan.org/pkg/eso-pic?lang=en
    \usepackage{pdfpages}
    \usepackage{pagegrid}
    \pagegridsetup{top-left}
\begin{document}
\section{hi}
Option pscoord does work, but texcoord option of eso-pic causes blank pages. But one can use pagegrid-package.
\includepdf[pages=-]{./prelims/myprelims.pdf}
\end{document}

Which looks like: enter image description here

4

Thanks for the report. I've just fixed it and will upload a new version to CTAN propably this week. If you would like to get a pretest version earlier send me a note by PM.

Update: Pdfpages, version 0.5e, is on CTAN since yesterday. It fixes the above-mentioned incompatibility with eso-pic's option `texcoord'.

  • 3
    Welcome to TeX.SX. Unfortunately this is not an answer yet, because this does not solve the question right now. Because of that it is likely that this answer will be deleted. When your update is available via CTAN, you are welcome to answer the question again. Thank you for your understanding. – Stefan Pinnow Apr 11 '16 at 18:55
  • Wow this is great news having a devoloper straightforward taking care of the issue, Appreciate it. – qrtLs Apr 11 '16 at 19:18
  • Ok. If this are the rules, it's fine by me. But please note that (since I do not have enough reputation points) the only alternative would have been to write nothing at all. – Andreas Matthias Apr 11 '16 at 19:36
  • @StefanPinnow: In my opinion this is a useful answer. It says that the problem is temporary and even explains how to get a pretest. I don't see how waiting until the package is on CTAN would improve it or be more useful to the OP. I 'm always grateful when a package author tells me that the next version will solve my problem. Also it would be useful if you upvote this answer so that Andreas gets enough reputation to write comments next time. – Ulrike Fischer Apr 13 '16 at 8:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.