0

I'm just starting with Latex and Bibtex, and now I've got a problem with the bibtex sorting. I am writing a bachelorthesis, where we have set a specific .bst file, the natdin.bst.

We have to sort the items by last name of the author/editor - that works perfectly. But then we have some other items like technical standards - these should appear in alphanumeric order, but BEFORE alle the other items like books/articels etc.

How can I manage to do that? Do I have to change the whole bibliography-style? Or is there a way to order them manually?

And then there is another thing: I get the error \begin{thebibliography}{27} (or the number, how much entrys I have in my .bib-file) when I compile my latex code. Seems that there is an item missing, but I don't know why, I am using TexShop on Mac with BibDesk for the bibtex-part.

The bibliography is done in tex by:

\bibliographystyle{natdin} 

which is included in an extra .sty-file, and

\bibliography{02__chapter/cite_bibliography} 

in the main.tex file.

Thanks a lot in advance

  • Please tell us more about these "other items like technical standards." Do they have a common entry type? Do they lack author and year fields? If so, how are they cited? Separately, do you use a citation management package such as natbib? – Mico Apr 11 '16 at 11:18
  • The entry type is book (at least for now, and that's how it seems to be standard). The used fields are title, publisher, year, author, address and optional keywords. I don't use a citation management package as far as I know - where could I find that? – Manu Apr 11 '16 at 16:02
  • Please confirm: You're using the entry type @book for "other items like technical standards". Separately, examples of citation management packages are natbib and cite. – Mico Apr 11 '16 at 17:27
  • jep thats right. That's how they told us to do :P Im using the management package cite – Manu Apr 12 '16 at 8:34
  • 1
    The header information in natdin.bst states unequivocally that this bibliography style must be used together with the natbib package. Note that the cite and natbib packages are mutually incompatible. I suggest you stop loading the cite package and start loading the natbib package, preferably with the options numbers and square. Be sure to re-run LaTeX, BibTeX, and LaTeX twice more to propagate all changes. – Mico Apr 12 '16 at 8:53
0

I've done a quick workaround, and now it works like it should. It may not be the best solution, but it fits my needs:

I defined a new command, which is empty:

\newcommand{\aaa}{}

It has 3 "a"s, because thats no common Latex command and this should likely be the first alphanumeric order ever - and if its not I can change it to e.g. \aaaa or more.

In the bibliography, I write in the author field:

\aaa{}{DIN1234}

Because Bibtex orders just after the characters, this entry will be put first in the bibliography. If I have some other entrys, I can easyly define some commands like \aab \aac etc, to put them in the correct order.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.