2

I have a resume written in Tex that was working just fine. I had to change my HD drive due to a problem. I installed Miktex 2.9 and TexMaker again and configured the packages to download and install on the fly. I'm using Windows 7 x64

When I build the file now, I'm getting several errors, but the first one is:

! Undefined control sequence.
<recently read> \str_case:nnn
l.31 {Fontin}
The control sequence at the end of the top line
of your error message was never \def'ed. If you have
misspelled it (e.g., `\hobx'), type `I' and the correct
spelling (e.g., `I\hbox'). Otherwise just continue,
and I'll forget about whatever was undefined.

I used this template. I downloaded it again, and out of the box it also doesn't build.

This is the portion of my file which (I think) is generating the error:

%FONTS
\defaultfontfeatures{Mapping=tex-text}
%\setmainfont[SmallCapsFont = Fontin SmallCaps]{Fontin}
%%% modified for Karol Kozioł for ShareLaTeX use
\setmainfont[
SmallCapsFont = Fontin-SmallCaps,
BoldFont = Fontin-Bold,
ItalicFont = Fontin-Italic
]
{Fontin}
%%%

I've installed the Fonts in my computer and they're also in the root of the .tex file.

Edit: As asked, here is a sample file that gives the same error:

\documentclass{article}

\usepackage{fontspec}
\setmainfont{Arial}
\begin{document}

\section*{Introduction}
This is Introduction

\end{document}

And here is the .log of the minimal example (Pastebin)

closed as off-topic by Torbjørn T., Kurt, barbara beeton, egreg, Przemysław Scherwentke Jul 2 '16 at 23:27

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Welcome! Try to make a complete, small document which produces the error when you compile it. We want a complete document starting with \documentclass and ending with \end{document} which gives that error when you compile it so that we can compile it and see if we get the error or not. – cfr Apr 12 '16 at 1:02
  • 1
    That is, test whether that code is needed to reproduce the error. If not, take it out. If so, see what else you can remove and still get the error. Eventually, you'll have a minimal example. That's what you want to post here. – cfr Apr 12 '16 at 1:04
  • 3
    Looks like an old version of fontspec. Can you post the full log where the files are loaded (should have lines like C:\Program files\MiKTeX\tex\latex\fontspec\fontspec.sty)? – Joseph Wright Apr 12 '16 at 5:54
  • 3
    fontspec is not up-to-date. Check that your miktex is really current. tex.stackexchange.com/a/108490/2388 – Ulrike Fischer Apr 12 '16 at 7:50
  • 4
    I'm voting to close this question as off-topic because it was solved by updating a package (fontspec). – Torbjørn T. Jul 2 '16 at 22:04