13

I have the following entry in my bib-file which contains the accented character \u\i:

@article {Gur1966SpacesUniversalPlacement,
    author = {Gurari{\u{\i}}, V. I.},
     title = {Spaces of universal placement, isotropic spaces and a problem of {M}azur on rotations of {B}anach spaces},
   journal = {Sibirsk. Mat. \v{Z}.},
    volume = {7},
      year = {1966},
     pages = {1002--1013},
} 

When I use BibTeX the correct entry is generated. Using Biber results in the following error message:

Undefined control sequence.
  Gurari{\ui 
                  }

It seems that the backslash in \u\i is removed. Is it possible to prevent Biber from doing this? Or more general, what is the proper way of using accented characters with Biber?

  • Just use the correct unicode character. – Johannes_B Apr 12 '16 at 8:37
  • By the way, in an up to date version of biber, this should be resolved. – Johannes_B Apr 12 '16 at 8:43
  • @Johannes_B: I tried to use the unicode character "ĭ" but then I ran into troubles with fontenc. It seems that ĭ is not in T1. – Christian Apr 12 '16 at 8:54
  • ĭ works fine for me with \usepackage[T1]{fontenc}. Perhaps your inputenc setting and/or the encoding of the bib is faulty. – Ulrike Fischer Apr 12 '16 at 9:12
  • 1
    @egreg That \u{\i} doesn't work is not really a surprise, but the direct input ĭ should work if the (input) encodings are correct and correctly declared. – Ulrike Fischer Apr 12 '16 at 9:27
12

There's a strange combination of factors that should be solved by different people.

  1. There's no predefined combination \u{i} in t1enc.def, so ĭ should be typed in as \u{\i}

  2. Biber transforms \u{i} into U+012D LATIN SMALL LETTER I WITH BREVE

  3. Biber transforms \u{\i} into U+0131 LATIN SMALL LETTER DOTLESS I U+0306 COMBINING BREVE

So the legal LaTeX input Gurari{\u{\i}} becomes a combination that makes sense to Unicode engines (XeTeX and LuaTeX) because of their normalization rules, but is pretty useless with pdflatex.

Solution: in the author field either type in

Gurar{\u{i}}

or

Gurariĭ

(the latter requires you load \usepackage[utf8]{inputenc}

  • the problem goes beyond that - the second character (U+0131) does not have coverage on some very standard fonts, like for example, Times New Roman, so the following code, even under xelatex produces a square in the place of the accent: \documentclass{report} \usepackage[utf8]{inputenc} \RequirePackage{fontspec} \setmainfont{Times New Roman} \begin{document} Oleı̆nik. \end{document} – Paulo Ney Apr 18 '18 at 21:08
  • @PauloNey If a font doesn't have the necessary glyphs, it's not the fault of the maintainers of Biblatex. Please make a new question with the details. – egreg Apr 18 '18 at 21:18
  • @egreg You are my hero of the day! (+1 of course). – Henrik Schumacher Aug 14 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.