5

Since several weeks all my TeXstudio installations show this irritating behaviour:

  1. Write a macro like \cite, \input, \SI, \gls, \label, ...
  2. Type the opening bracket {
  3. As soon as typing the { the CPU load rises to 100 % and TeXstudio is unresponsive for several seconds. I can type anything and the letters appear one after another - each after some seconds. When I don't type, the CPU goes down again until I type another letter.
  4. As soon as typing the closing bracket } everything is fine again.

It happens most of the time, but not always. The same happens with copy and pasting those macros.

It mainly seems to be related to linking/referencing/including macros. This does not happen with stuff like \footnote, \emph etc. On the other hand, \dfrac is also suffering from this.

I tried deactivating interactive checking of citations, references and syntax in the options editor tab. No change of this.

I run TeXstudio 2.10.8 in Manjaro Linux on three different machines.

Anyone the same issue or an idea?

  • I've had a similar thing in TeXstudio when altering the document class. I thought it was because I've got a very large file, so I'm not sure if our problems are symptoms of the same issue or not. – astronat Apr 12 '16 at 12:11
  • I don't use it, but this is something like a search for completions going awry, like trying to look into very big files or directories. Maybe you can strace it to see which files it opens and look if there something strange... – Rmano Apr 12 '16 at 12:32
  • To see all the files a program opens, you can use strace program 2>&1 | grep "open" on Linux system. There will be a lot of system files and libraries at start, but after that if you reproduce the problem it can point you to the error. – Rmano Apr 12 '16 at 12:35
  • Nice tool, didn't know strace. Unfortunately, it opens files all the time - when pointing somewhere etc. - but when TeXstudio freezes after typing a macro nothing is opened. Doesn't seem to be a problem with loading big files. Even though my bibliography is big indeed: it always was and e.g. the siunitx files have not changed neither. – monoceros84 Apr 12 '16 at 13:12
  • In parallel I have filed a bug report... sourceforge.net/p/texstudio/bugs/1736 – monoceros84 Apr 12 '16 at 13:18
1

Ok, so I found a temporary solution. By deactivating the option "load included files automatically" (just translated from German to English, no guarantee it's exactly named like this) in the editor's tab of TeXstudio's options the freezing behaviour is gone.

But of course I'll have to find all the references, citations etc. manually now. Not much better than using an ordinary text editor... So it's a way to work again, but not the way I like to have.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.