2

In acro package, version v2.4 the option messages={silent} is not working as expected.

In the MWE below, the acronym is not defined. But with the option messages={silent} it should be ignored, issuing an error, but keep on with the compilation.

\documentclass{article}

\usepackage{acro}
\acsetup{messages={silent}}

\begin{document}

\ac{AAA}

\end{document}
  • The error comes from deeper than acro, because it is Missing number, treated as zero, so a TeX error. It seems a bug in acro. – egreg Apr 12 '16 at 21:06
  • Bug messages are best made here bitbucket.org/cgnieder/acro (and if something's not working as advertised I consider it a bug) – clemens Apr 13 '16 at 0:06
  • It is easier to put them here :). I may write in the bitbucket, but I do not know exactly where. – cacamailg Apr 13 '16 at 0:16
  • @cacamailg no, it's not easier – on bitbucket you can be sure that I'll see the issue and will try to find a fix. Here it is just luck that I saw your question so fast (and also that I remembered it today)… It's quite easy to find on bitbucket: click on issues and create new: bitbucket.org/cgnieder/acro/issues/new – clemens Apr 13 '16 at 9:25
  • @cacamailg actually the silent option is working: using an undefined acronym issues an acro warning, not an acro error. I fixed it anyway. The new version is available on bitbucket.org/cgnieder/acro and will be uploaded to CTAN in the next days… – clemens Apr 13 '16 at 9:48
3

With v2.4a (2016/04/14) or newer there is no error any more.

\documentclass{article}

\usepackage{acro}[2016/04/14]
\acsetup{messages={silent}}

\begin{document}

\ac{AAA}

\end{document}
  • I will need to wait for TeXLive 2016. However, I will accept your answer. Thanks for taking care of this "bug". – cacamailg May 9 '16 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.