I want to use the numeric-comp style of biblatex to produce cites like [1-3]. Unfortunately, all I ever get is [1, 2, 3]. Any ideas what could be the problem?

A minimal tex-file is:

MadAnalysis \cite{madanalysis2013, madanalysis2014, madanalysis2015}

and my (reduced) bibliography looks like this:

    author          = {E. Conte and B. Fuks and G. Serret},
    title           = {MadAnalysis~5, a user-friendly framework for collider phenomenology},
    journal         = {Comput. Phys. Commun.},
    year            = {2013},
    volume          = {184},
    number          = {1}
    author          = {E. Conte and B. Dumont and B. Fuks and C. Wymant},
    title           = {Designing and recasting LHC analyses with MadAnalysis~5},
    journal         = {Eur. Phys. J. C},
    year            = {2014},
    volume          = {74},
    number          = {10}
    author          = {B. Dumont and B. Fuks and S. Kraml and S. Bein and Weitere},
    title           = {Toward a public analysis database for LHC new physics searches using MADANALYSIS~5},
    journal         = {Eur. Phys. J. C},
    year            = {2015},
    volume          = {75},
    number          = {2}

Running pdflatex, biber, pdflatex (Texlive 2015, Biber 2.1) however produces only:

MadAnalysis [1, 2, 3]

  • 1
    Adding the option citestyle=numeric-comp should work. B.t.w. you should update to biber 2.4 and biblatex 3.3.
    – Bernard
    Apr 12, 2016 at 22:25
  • Or simply write style=numeric-comp for both.
    – Bernard
    Apr 12, 2016 at 22:27

1 Answer 1


It comes from writing only bibstyle=numeric-comp as an option. If you want to compress also citations, you have to add citestyle=numeric-comp, or better, if you want it for both, simply style=numeric-comp.

  • 1
    Indeed bibstyle=numeric-comp is equivalent to bibstyle=numeric and as such changes nothing from the default (style=numeric).
    – moewe
    Apr 13, 2016 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.