2

in my report I have to write the city word Umeå once. I have included \usepackage[english,swedish]{babel} but the result is

enter image description here

Not exactly right :/ Is it possible to just write the letter Å without including Swedish in babel?

The packages used in the report is

\documentclass[paper=a4, fontsize=11pt]{scrartcl} % A4 paper and 11pt font size
\usepackage[T1]{fontenc} 
\usepackage{fourier}
\usepackage[english,swedish]{babel}
\usepackage{amsmath,amsfonts,amsthm}
\usepackage{graphicx}
\usepackage{caption}
\usepackage{array}
\usepackage{verbatim}
\usepackage{tikz}
\usepackage{changepage} 
\usetikzlibrary{decorations.pathreplacing}
\usetikzlibrary{calc}
\usepackage{sectsty} 
\allsectionsfont{\centering \normalfont\scshape} 
\usepackage{fancyhdr} 
\pagestyle{fancyplain}
  • 2
    Your file is probably UTF-8 encoded and you have \usepackage[latin1]{inputenc}. Change latin1 into utf8. No need to enable Swedish. – egreg Apr 13 '16 at 20:58
  • Sorry. I don't have that package. See my question amended with all the packages included in the document. – Orongo Apr 13 '16 at 21:00
  • 1
    Then add \usepackage[utf8]{inputenc}. And remove swedish. – egreg Apr 13 '16 at 21:03
5

Here's a minimal example reproducing the problem.

\documentclass{article}
\usepackage[T1]{fontenc}
\begin{document}
Umeå \textsc{Umeå}
\end{document}

The file was saved as UTF-8 and the output is

enter image description here

Change it to

\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\begin{document}
Umeå \textsc{Umeå}
\end{document}

and you'll get

enter image description here

There is no need to load babel-swedish for typesetting the character å.

  • I changed but get compile error. "! Package babel Error: You haven't loaded the option swedish yet. See the babel package documentation for explanation. Type H <return> for immediate help. ... l.3 \select@language{swedish} ? " – Orongo Apr 13 '16 at 21:15
  • @Orongo That's a temporary error, because you disabled a language. Remove the .aux file and retry. – egreg Apr 13 '16 at 21:23
  • question shows small caps. should get equivalent result with what you've answered, but it would be nice to see it. – barbara beeton Apr 14 '16 at 2:39
  • 2
    @barbarabeeton Added – egreg Apr 14 '16 at 8:13
1

How about: \r{a}

I don't think any package needed. See: https://en.wikibooks.org/wiki/LaTeX/Special_Characters#Escaped_codes

  • 1
    I'm against typesetting accented letters with TeX constructs. All systems understand UTF8 nowadays, and it's really painful to read such coding. – Bernard Apr 13 '16 at 21:11
  • I can't find the letter I am looking for in the link. – Orongo Apr 13 '16 at 21:13
  • @Orongo How about \r{a} or even better \aa? I can find that on the linked page. – Johannes_B Apr 14 '16 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.