2

I'm currently trying to build a document with XeLaTeX because I need it for a template. My OS is Scientific Linux 7.2 and I use texlive + Texstudio as an editor.

Now the problem that I have is that whenever I try to compile with XeLaTex, none of my installed packages are found, e.g. braket, bbm, nccmath, .... However, if I compile with PdfLaTeX all packages are found. According to 'tlmgr list --only-installed' all of these packages are properly installed.

Do I need to kind of 'register' the packages in XeLaTeX, or why doesn't it find anything? Feels like a dumb question, but I haven't found anything on google or stackexchange.

Thanks a lot!

closed as off-topic by user36296, CarLaTeX, Zarko, Mico, barbara beeton Oct 1 '17 at 14:09

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • The obvious next step: what does xelatex (the command) from the commnd line manage to find? Next compare which pdflatex and which xelatex. – jon Apr 14 '16 at 2:49
  • Welcome! If things are as described, then something is very wrong with your TeX installation. Providing the exact error message generated when you compile a minimal document and including the code of that document here would enable people to say something more helpful. – cfr Apr 14 '16 at 2:50
  • Perhaps it might be your choice of Linux and the way its security may be set up. I know that texlive works very predictably on a Debian based or Redhat\Fedora based install. Unless you really need to use Scientific Linux another choice might ease installation problems. Of course, if you are running something along the lines of the Large Hadron Collider... – A Feldman Apr 14 '16 at 3:43
  • 2
    You have 2 installations of TeX. This is the problem. One is installed with your Linux distro's package manager, I assume (yum/dnf). The other is from upstream (install-tl). You need to decide which you want to keep and remove the other. If you want to keep upstream's, you need to take some steps to convince yum/dnf that TeX Live is installed. Although a bit more complex initially, this is the recommended option and often more straightforward overall. – cfr Apr 15 '16 at 11:53
  • 4
    I'm voting to close this question as solved in comments – user36296 Oct 1 '17 at 12:24