2

I use the package semtrans in order to print Arabic letters in a Table in my document.

My problem is that line spacing between two lines of Arabic letters (probably because of the used font) in the output is too large in the table. I tried the command \singlespacing but the space is still too big.

Here my example:

\documentclass[12pt]{book}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{arabtex}
\usepackage{semtrans}
\usepackage{longtable}
\usepackage{tipa}

\begin{document}
\begin{longtable}{ | m{3cm} | m{3cm}| m{3cm} | m{3cm} | } 
\hline
\textbf{Transliteration} & \textbf{Arabic Letter} & \textbf{Name} & \textbf{IPA Symbol}  \\
\hline  
\Alif & \begin{RLtext}"' \end{RLtext} \setarab& \textit{hamza} & \textglotstop \\ 
\hline
\textit{\={a} / a /u / i}  & \begin{RLtext}A \end{RLtext} \setarab &\textit{\Alif alif \textsubdot{t}aw\={\i}la} & a: / a / u / i \\
\hline

\textit{\^{a}}& \begin{RLtext}Y\end{RLtext} \setarab &\textit{\Alif alif maq\textsubdot{s}\={u}ra} & a: \\
\hline
\textit{b}& \begin{RLtext}b \end{RLtext}\setarab &\textit{b\={a}\Alif} & b \\
\hline
\textit{t}&\begin{RLtext}t \end{RLtext}\setarab &\textit{t\={a}\Alif} & t \\
\hline
\end{longtable}

\end{document}

Does someone have any idea, how to make the distance smaller?

Thank you!

2
  • Welcome to TeX.SE! Your verbal description of the issue is compatible with many kinds of inputs, and thus doesn't help narrow down the cause(s) of the problem. Please provide a compilable MWE that generates the problem that needs to be fixed.
    – Mico
    Commented Apr 14, 2016 at 11:10
  • By the way, no need to encase a longtable enviroment inside a center environment -- a longtable is automatically centered.
    – Mico
    Commented Apr 14, 2016 at 11:40

2 Answers 2

2

Instead of RLtext environment to insert arabic text you can use \RL{arabic text} for inserting short arabic text inside latin paragraphs.

\documentclass[12pt]{book}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{arabtex}
\usepackage{semtrans}
\usepackage{longtable}
\usepackage{array}
\usepackage{tipa}

\setarab
\begin{document}

\begin{longtable}{ |m{3cm}|m{3cm}|m{3cm}|m{3cm}| } 
\hline
\textbf{Transliteration} & \textbf{Arabic Letter} & \textbf{Name} & \textbf{IPA Symbol}  \\
\hline  
\Alif & \RL{"'} & \textit{hamza} & \textglotstop \\ 
\hline
\textit{\={a} / a /u / i}  & \RL{A}  &\textit{\Alif alif \textsubdot{t}aw\={\i}la} & a: / a / u / i \\
\hline

\textit{\^{a}}& \RL{Y} &\textit{\Alif alif maq\textsubdot{s}\={u}ra} & a: \\
\hline
\textit{b}& \RL{b} &\textit{b\={a}\Alif} & b \\
\hline
\textit{t}& \RL{t} &\textit{t\={a}\Alif} & t \\
\hline
\end{longtable}

\end{document}

enter image description here

0
0

I found a part-solution, by adding \usepackage{setspace}to the preamble and adding \begin{spacing}{.6} before and \end{spacing}after the table. Now I need only to disable this command for the first row of the table. Any ideas how it can be done? Thank you!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .