2

I want to cite an entry related to another entry such that the child entry appears in the bibliography.

MWE

\documentclass{article}
\usepackage[style=verbose,backend=biber]{biblatex}
\addbibresource{biblatex-examples.bib}
\begin{document}
\cite{kullback:related}
\printbibliography
\end{document}

Constraints

In the above MWE:

  • both kullback:related and kullback must appear in the bibliography unless explicitly skipped using the skipbib option.
  • kullback must not necessarily be cited independently.
  • must be able to have mincrossrefs>1.
  • ideally only one pass of biber and latex.

Methods I've tried

  • use a custom myref field to point to the child entry and add an explicit \nocite{\thefield{myref}} within a custom driver. This works but has two undesirable side effects:

    1. It requires an extra pass of biber and latex.
    2. It does not work with the current dev version of biblatex (See issue #407).
  • using xref with the \entrydata macro and mincrossrefs=1. This works, but I need it to work with mincrossrefs>1.

A possible way forward

Explain to me how the xref field works such that I can modify it (or my custom myref field) to be included regardless of the value of mincrossrefs. The crossref field must continue to respect the value of mincrossrefs as outlined in the biblatex manual.

2 Answers 2

2

Please try the latest biblatex 3.4 and biber 2.5 from Sourceforge. minxrefs is now a separate option when using biber - this was something planned a while ago but for some reason never implemented. The biblatex macros were already in place but biber needed some changes. These options are part of the backend functionality and so with the bibtex backend, mincrossrefs still controls xrefs too. There cannot be a separate option for this with bibtex as there is no such option for the bibtex program (since it's a biblatex concept).

3
  • As noted in my comment in issue #407, this is good! But it fails my first constraint if the skipbib option is set in kullback:related. This is only apparent in verbose styles. I've amended my MWE. Apr 15, 2016 at 2:18
  • Can you add the bib entries to the MWE to make it really "W"?
    – PLK
    Apr 15, 2016 at 8:42
  • I don't think this has anything to do with skipbib - it's a fairly complex interaction of things which I think are fixed now in the the latest 3.4/2.5.
    – PLK
    Apr 15, 2016 at 22:08
1

An additional useful piece of information which directly answers the question (although not with all constraints).

You can force a related entry to appear in a bibliography by overriding the relatedoptions field. e.g., relatedoptions = {dataonly,skipbib=false}.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .