My tex file has backend=biber in the header. But, as I use tex-live 2009, biber is not installed by default. I downloaded the biber.tar.gz from the biber project page at sourceforg., When I extracted it, it had only one file named biber. I placed it in /usr/bin dir and made it executable. And I ran biber my_paper.aux and it showed an error: /usr/bin not found.

I cloned the git dev project of biber. And when I tried building it, it showed up lots of dependancy issues.

So is there an easy way to get biber working on my 32bit ubuntu 11.04 system?


1 Answer 1


I've installed biber on both 32- and 64-bit versions of Ubuntu in essentially the same way you described with no problems, although I put the extracted biber in /usr/local/bin. The error you describe sounds strange, though. What happens if you run (say):



If that works as expected, then I'd delete older versions of biber, extract a new copy, make it executable, and try this sequence:

  • first: make sure backend=biber is an option you're giving to biblatex;
  • run your file (my_paper.tex) through (say) latex (this should create a file with a .bcf extension);
  • then run biber my_paper or biber my_paper.bcf (not biber my_paper.aux).

If you're having trouble with these steps, then can you even run biber -v to check your version. (I get biber version: 0.9.6 (beta) when I run the command.)

Another thing to check is that your biblatex and its related packages (etoolbox, logreq, and, ideally, csquotes) are also up to date --- although I can't see how this could relate to the more profound error you seem to be experiencing.

EDIT: you may want to look at the biber documentation as well: http://sourceforge.net/projects/biblatex-biber/files/biblatex-biber/development/documentation/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .