1

I use lualatex, or xelatex, and biberand bibaltexand polyglosia to compile my document. I prefer to load biblatex first if possible. I want the french language as main language for the document, but I want the british language as main language for the bibliography. My problem is that my bibliography, which is all in english, is displayed with french words, instead of english words.

This is the order that I load things:

\usepackage[bibstyle=ieee-alphabetic, language=british]{biblatex}

\usepackage[T1]{fontenc}
\usepackage{fontspec}
\usepackage{polyglossia}
\setmainlanguage{french}

this is what prints the citations

\newrefcontext[sorting=nyt]
\selectlanguage{english}
\printbibliography[title= Bibliography]
\endrefcontext

Loading biblatex after polyglossia does not change the french display of my english bibliography.... Also, no entry in my bibliography has a field language={english} and it would take too long to add this field manually.

closed as unclear what you're asking by Mensch, Jesse, Zarko, egreg, Mico Sep 1 '16 at 17:28

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Polyglossia support has been a bit complicated at times (and in fact there were quite some problems until recently). The language options had some issues that should be fixed in the upcoming version 3.4 (see issue #385 as well as How to switch the bibliography to English in a document with another default language? which may very well be a duplicate) – moewe Apr 16 '16 at 17:01
  • 2
    You can make your problem much easier to investigate for other people if you provide a full compilable example (an MWE) and not just some snippets of code people need to piece together not knowing if their result remotely resembles what you have. – moewe Apr 16 '16 at 17:04
  • 1
    Your first problem is that biblatex really needs to be loaded after polyglossia. Is there any real reason why you prefer to load it earlier? – moewe Apr 16 '16 at 17:07
  • 1
    @moewe is correct, you must load biblatex after polyglossia so that is can detect polyglossia and set up some internals. – PLK Apr 16 '16 at 21:02

Browse other questions tagged or ask your own question.