1

I just installed MikTeX v. 2.9

I have used MFTI 0.60 with older versions of MikTeX with no problem..

MikTeX 2.9 did away with localtexmf and texmf directories. I tried to figure what to use for MikTeX base directory and MikTex local directory.

I guessed C:/Program Files/MiKTeX 2.9 for the base directory since that is where MiKTex is.

I guessed C:/Documents and Settings/George/Application Data/MiKTeX/2.9 since that seems to be my local MikTex directory.

I got the "green check marks" beside both entries on the MFTI entry screen

Before the final step, MFTI printed the summary as follows:

-------------------------------------------
Conclusion of your selections
Normal font: C:/Temp/FineHand.ttf
Bold font: C:/Temp/FineHand.ttf
Italic font: C:/Temp/FineHand.ttf
Bold and Italic font: C:/Temp/FineHand.ttf
MiKTeX base installation dir: C:/Program Files/MiKTeX 2.9
MiKTeX local installation dir: C:/Documents and Settings/George/Application
Data/MiKTeX/2.9
Name of the new Font: finehand
Output directory: C:/Documents and Settings/Georgebut
-------------------------------------------

Then when I tried to finish got an error:

--------------------------------------------------
X Encoding File "C:\Program Files\MiKTeX 2.9\ttf2tfm\base\T1-WGL4.enc" not
found

X *** Font Installation failed! ***
--------------------------------------------------

Here is the advice from the MiKTeX 2.9 manual but I am not sure how to interpret it or apply it to this situation:

The Local TEXMF Tree you might remember from older versions of MiKTeX is unfortunately no longer supported. You can place your own packages, classes, and configuration files one of three directories grouped together in C:\Documents and Settings. You can find the exact path via the Windows menu Start ? All Pro-grams ? MiKTeX 2.9 ? Maintenance ? Settings. In the window that appears, click on the tab labelled Roots. You can also add an existing Local TEXMF Tree (normally located in ? C:\localtexmf) to MiKT E X 2.9?s search path with the same Roots tab.

I think I need help identifying the base installation dir and the local installation dir.

I would appreciate your suggestions!

Please also be aware that I use only plain TeX not LaTeX, if that would make a difference.

  • Did you follow the instructions you've posted above? – cfr Apr 19 '16 at 2:50
  • Yes I did follow the instructions to the best of my ability but there was an issue as to what was intended by the main installation directory and the users installation directory. If you look at the log transcript I think you'll see that I did provide appropriate responses to the input fields. If you can think of anyway I can do this manually let me know. For example if I could just use Ttf2afb etc and also make the appropriate entries to other necessary files including map files and TFM files I would do it – GAS4 Apr 19 '16 at 2:57
  • The error message says that T1-WGL$.enc is not found. In my system it is in fonts/enc/ttf2pk/base/T1-WGL4.enc, MFTI seems to be looking at another place for it. So you could try to copy the file. Don't forget to update the FNDB. I wouldn't use a miktex root for the local installation. Create a new folder called e.g. localtexmf with some minimal folder structure in it (tex/latex, fonts) and attach it as a new root in miktex settings. – Ulrike Fischer Apr 19 '16 at 6:34
  • I meant the stuff about the Start menu etc. It sounds as if the second option is the best one from @UlrikeFischer 's comment above. – cfr Apr 19 '16 at 11:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.