4

I kinda have the exactly the same problem as the

Citation "et al." only for four and more authors with natbib and jf.bst

except that I'm using apalike2.bst

What I did was the following: I copied the file apalike2.bst to my folder and renamed it to jf3.bst (no creativity for the name) Then, I copied the functions

FUNCTION {bbl.and}
{ "and"}

FUNCTION {space.word}
{ " " swap$ * " " * }

to the file. Last, I replaced the FUNCTION{format.lab.names} by the one in the referred link above. For one, two, four or more authors everything is working well but when i have three authors the last name of the last author and the year of the work is no appearing. For example, in the reference

@article{KrohlingMauro2011,
title = "Swarm algorithms with chaotic jumps applied to noisy optimization problems ",
journal = "Information Sciences ",
volume = "181",
number = "20",
pages = "4494 - 4514",
year = "2011",
issn = "0020-0255",
author = "Eduardo Mendel and Renato A. Krohling and Mauro Campos"
}

what I am getting is (Mendel, Krohling) using \citep and Mendel (Krohling) using \citet and what I'd like would be (Mendel, Krohling & Campos, 2008) or Mendel, Krohling & Campos (2008)depending if it is citet or citep. Oh, and I also change bbl.and to

FUNCTION {bbl.and}
{ " \& "}

closed as off-topic by Mensch, Joseph Wright Sep 12 '16 at 13:51

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Please tell us more about what exactly you have done. And, do tell us whether you re-ran LaTeX, then BibTeX, and then LaTeX twice more after creating the modified version of the apalike2 style. – Mico Apr 19 '16 at 7:18
  • Thank you @Mico. I edited the question to explain in a more detailed manner. About the compiling, procedure, yes, i re-ran Latex, Bibtex and Latex. – Rodolfo Apr 19 '16 at 13:55
  • 2
    I've looked into the code in apalike2.bst, and I am able to replicate the problem you've encountered. Unfortunately, I seem to be unable to diagnose the cause of the problem, let alone provide a fix. I would therefore like to suggest that you acquaint yourself with the makebst utility, which is part of the custom-bib package. It provides a question-and-multiple-choice format, and at the end you will have a custom-built bibliography style file. – Mico Apr 19 '16 at 19:45
  • 1
    Yes, makebst solved my problem. If I remember correctly, the problem was something with the language....I don't remember exactly, but I was able to fix it using makebst. – Rodolfo Sep 6 '16 at 20:20
  • 1
    I'm voting to close this question as off-topic because it is solved by comments. – Mensch Sep 12 '16 at 13:21

Browse other questions tagged or ask your own question.