2

I've been using Lyx and an MIT Template that is available from the link below (also including a minimal example) to write my Formal Lab reports for my undergraduate Physics labs. I (and my tutors) have noticed arbitrary indentations and spacing occassionaly throughout my report when I use this template.

MIT Lab Report Template w/ Minimal Example

Here's an image of an extreme case from one of my lab reports:

enter image description here

I would upload put in the minimal example code provided by MIT, but I'm not too sure how to do it; my knowledge of Latex code is very small since I primarily use Lyx

Thanks in advance :)

Edit: If you need anything in particular that would help you figure out what the problem is (e.g. a Lyx file of my Lab report) then feel free to ask :)

Here's a Lyx File. Notice that once you remove the tables, the spacing disappears (but whenever they are there, the spacing between the Conclusion section and the following paragraph is very large).

Lyx File

  • Wild guess: try adding \raggedbottom to Document --> Settings --> LaTeX preamble. – Torbjørn T. Apr 20 '16 at 6:53
  • Thanks for the comment, I've already attempted that and doesn't work – charl1e Apr 20 '16 at 8:32
  • Ok. Can you make a small example demonstrating this behaviour, and add either the complete LaTeX code or the .lyx file itself to your question. – Torbjørn T. Apr 20 '16 at 9:30
  • I added the lyx file itself. I removed most of the unnecessary stuff, again notice that the spacing only exists when the tables are there... – charl1e Apr 20 '16 at 11:58
3

The problem in your example is caused by the class option balancelastpage. This option causes the columns on the last page to be balanced, i.e. have the same height. If you go to Document --> Settings --> Document class, and change balancelastpage to nobalancelastpage, you'll get a different result.

  • Awesome! Thanks so much :) I'm just about to upload a second file (my full lab report) where my tutor pointed out a random indent. If you have more time on your hands, this has been bugging me! – charl1e Apr 20 '16 at 12:34
  • @charl1e Full files at external sites are not really ideal, much better if you make the smallest example you can that demonstrates the problem (like the one you posted), and then do one of two: 1) Open the Source pane in LyX, select complete source instead of current paragrah. Copy the whole thing, and paste it into your question. 2) open the .lyx file in a text editor (notepad, Notepad++, Gedit, Textedit, etc.), select everything, and copy-paste it into your question. – Torbjørn T. Apr 20 '16 at 12:40
  • @charl1e If you mean the text immediately after the equation, it's because you've added a paragraph break after the equation, so the paragraph is indented with the standard paragraph indent. Place the cursor at the start of that paragraph, and hit backspace once. – Torbjørn T. Apr 20 '16 at 12:47
  • Jesus. Can't believe I didn't notice that... Thanks so much for your time, it's greatly appreciated! (I would have never of figured out the fix to the 'balancelastpage' problem) Thank you so much – charl1e Apr 20 '16 at 13:11
  • @charl1e If you go to Tools --> Preferences --> Look and feel, there is an option for Mark end of paragraph. When active, you get a pilcrow in the LyX GUI at the end of paragraphs. You can also see it from the fact that the indentation is there also in LyX. (I found the balancelastpage by accidentally reading the documentation which is added as comments in the start of the source.) – Torbjørn T. Apr 20 '16 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.