1

Here is the minimal example, it appears that the hyphenation does not work properly here.

\documentclass[a4paper]{article}
\usepackage[a4paper, total={6.5in, 9.0in}, headsep=50pt]{geometry}
\usepackage{lipsum}

\begin{document}

\lipsum[1-3]

\end{document}

enter image description here

4
  • 'Nothing to do here': the log shows now overfull boxes so TeX doesn't hyphenate (you can see more details by tracing the run). Of course, hyphenation of cod-Latin using English patterns is going to be a bit odd anyway.
    – Joseph Wright
    Apr 21 '16 at 5:57
  • Well, there are some huge strange white spaces, and even when i type something in english the hyphenation wont kick in. Apr 21 '16 at 6:07
  • The screenshot is fine so please post a short example which shows this issue, and ideally the log to go with it.
    – Joseph Wright
    Apr 21 '16 at 6:12
  • As @JosephWright points out that hyphenating lipsum text might be a bit troublesome, perhaps you might get clearer results with`kantlipsum' which uses English words.
    – Chris H
    Apr 21 '16 at 8:38
3

TeX puts some penalty on each hyphen, so it avoids hyphenation when it is not really necessary. And, in this example, hyphenation is indeed not needed: There are neither overful nor underful hboxen.

The large spaces you are noticing are spaces after a full stop at the end of sentence (an example is the space after Cras nec ante.). Turn on \frenchspacing (by using this command in the preamble) to make the spaces after a full stop equal to normal word spaces.

1
  • The problem was with \frenchspacing. Now the text looks like i want it to. Thanks Apr 21 '16 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.