1

I am trying to show the bibliography in a LaTeX document. But \printbibliography does nothing. I am using biblatex with bibtex8 as backend. Here is the code:

\documentclass[liststotoc,bibtotoc,a4paper,12pt,parskip,final]{scrbook}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{ae,aecompl}
\usepackage[ngerman]{babel}
\usepackage{setspace}
\usepackage{graphicx}
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[backend=bibtex8]{biblatex}
\usepackage{hyperref}
\usepackage[nolist]{acronym}
\usepackage[paper=a4paper,left=25mm,right=25mm,top=30mm,bottom=40mm,bindingoffset=1cm]{geometry}
\hbadness = 10000 % -> disable ``underfull \hbox'' warnings
\parindent 0pt % keine einrückung nach absätzen
\bibliography{literature}

\begin{document}
    \frontmatter % keine kapitelnummern, römische seitenzahlen
    \include{./texFiles/titelblatt}
    \onehalfspacing
    \tableofcontents
    \listoffigures
%   \include{./texFiles/abkuerzungsverzeichnis}
    \mainmatter
    \include{./texFiles/01_einleitung}
    \include{./texFiles/02_grundlagen}
    \include{./texFiles/03_konzept}
    \frontmatter
    \setcounter{page}{15} % seitenzahl counter auf 15 setzen
%   \include{./texFiles/literaturverzeichnis}
    \printbibliography
\end{document}

Any idea what the problem is?

  • welcome! Any error or warning messages? – naphaneal Apr 22 '16 at 16:44
  • hi and thank you. no errors, but warning messages: Class scrbook Warning: You've used obsolete option liststotoc'. Class scrbook Warning: You've used obsolete option bibtotoc'. Class scrbook Warning: Usage of deprecated font command `\sf'! LaTeX Warning: Citation 'DJ-2015' on page 1 undefined on input line 2. ) LaTeX Warning: Empty bibliography on input line 40. LaTeX Warning: There were undefined references. Package biblatex Warning: Please (re)run Biber on the file: the warning "LaTeX Warning: Empty bibliography on input line 40." are very mysterious... the bib file is not empty. – DynamicBit Apr 22 '16 at 16:50
  • Did you actually run BibTeX8 on your files? If so there should be a .blg file, what does it say? – moewe Apr 22 '16 at 16:51
  • a .blg is not created. iam using texmaker with the quick compile function in default mode. – DynamicBit Apr 22 '16 at 16:56
  • Then your editor is not set up to run BibTeX or quick compile doesn't run a bibliography tool. (Check the menu for a bibliography compilation option) You can try and adapt the strategy for Biber in Biblatex with Biber: Configuring my editor to avoid undefined citations, see also Bibliography in Texmaker. You might also want to consider switching from the legacy backend BibTeX8 to the up-to-date Biber. – moewe Apr 22 '16 at 17:01
2

Well, there are several problems in your code, some related to KOMA-Script, some to called, outdated packages.

Your code gives you several warnings you should read and then change your code like this:

\documentclass[%
  listof=totoc,
  bibliography=totoc,
  paper=a4,
  fontsize=12pt,
  parskip,           % <==================== then \parindent not needed! 
  final
]{scrbook}

Then you have the line \usepackage{ae,aecompl} calling two outdated packages. Do not use this packages any longer!

If you use option parskip for class scrbook, then you can delete the line

\parindent 0pt % keine einrückung nach absätzen

At last you need to cite one or more bib entrys so that biber or bibtex are able to build an bibliography. I added command \nocite{*} and used the BibLaTeX example bib file biblatex-example.bib.

And of course you have to be sure that the following order of program calls is done: pdflatex mwe.tex, bibtex mwe or biber, pdflatex mwe.tex, pdflatex mwe.tex. If you have problems with the used editor (usually bad configuration) use a terminal or console and use the above given commands to create your document. If that runs, your TeX distribution is okay, and you can check the configuration of your editor ...

Complete MWE with commented packages from your example, which are not needed to show your problem:

\documentclass[%
  listof=totoc,
  bibliography=totoc,
  paper=a4,
  fontsize=12pt,
  parskip,           % <==================== then \parindent not needed! 
  final
]{scrbook}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
%\usepackage{ae,aecompl} % <====================== outdated, do not use!
\usepackage[ngerman]{babel}
%\usepackage[paper=a4paper,left=25mm,right=25mm,top=30mm,bottom=40mm,bindingoffset=1cm]{geometry}

%\usepackage{setspace}
%\usepackage{graphicx}
\usepackage[babel,german=guillemets]{csquotes}
\usepackage[%
  backend=bibtex8, % bibtex8 biber % <==================== change as needed!
]{biblatex}
\usepackage{hyperref}
%\usepackage[nolist]{acronym}

%\hbadness = 10000 % -> disable ``underfull \hbox'' warnings
%\parindent 0pt % keine einrückung nach absätzen
\addbibresource{biblatex-examples.bib}

\begin{document}
\nocite{*}
\printbibliography
\end{document}

and the result:

enter image description here

If you change from BiBTeX to Biber, you have to change the backend for biblatex (change in line backend=bibtex8, % bibtex8 biber in my MWE =biblatex8 to =biber) and you need to start program Biber instead of BiBTeX (see commands shown above).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.