1

I have been using 'sublime text 3' for a long time and I like it very much. It has limited support for LaTeX. Since I have to write reports in LaTeX I want to do it in 'sublime'.

I installed 'LatexTools' and 'Latexing', but it didn't compile saying

latexmk has not been found.

After some digging I installed texlive which was supposed to solve the problem but now I got

TraditionalBuilder: Engine: pdflatex. Invoking latexmk...
"Could not compile".

Can somebody write step by step, what to install and what to change/update to get this to work?

UPDATE: Ok so... I installed texlive using basic installation and without elevated permissions. Then, in sublime I switched distro to texlive and added custom build "cmd":["path_to_pdflatex.exe","$file"] and it worked for example document from sublime snippets. Great, but I need to write it using template from my teacher which has for example polish language and FreeBSD hyphenation, so compiling this threw more errors. Now I am installing texlive full package and see will that help. So far adding each new line gets me new error :D

  • Did you install a TeX distribution? – egreg Apr 23 '16 at 16:33
  • Yes I did install TeX distribution. And more, I opened cmd in folder where pdflatex.exe is and started compilation typing pdflatex.exe file.tex and it went smoothly. So the problem lies in sublime. – Mike Apr 23 '16 at 16:35
2

So, as you discovered, you need a TeX distribution and you've installed that, which is great. A couple of other points.

  1. LaTeXTools and LaTeXing don't play well together. Among other things, their keybindings overlap. Choose between the two of them and uninstall the one that you do not want to use.

  2. It's possible that you haven't installed latexmk if you managed to do a minimal install of TeXLive. You can install that by running tlmgr install latexmk. You will need to do this from an elevated command prompt, assuming you installed TeXLive with elevated permissions (this is most likely).

  3. Assuming you choose to use LaTeXTools (I don't really know anything about LaTeXing), you'll want to open the LaTeXTools user settings and find the setting called "distro". Change the value of that from "miktex" (the default) to "texlive".

  4. LaTeXTools (at least) assumes you'll be using SumatraPDF, so it's best to install that as well. LaTeXTools doesn't currently support any other PDF viewers on Windows (among other things, most of them don't support forward- and backward- sync capabilities).

Once you've done the above, things should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.