2

I am not sure why I do not see the expected format of referencing. I would like to see this kind of ref on a paragraph (vassiliadis et al., 2009) instead of [1]. For example, data fetched from open sources lacks quality [1] but I would like to see like this:

data fetched from open sources lacks quality (vassiliadis et al., 2009).

I am using \citep{vassiliadis2009survey} to make this happen but no luck so far.

I added the package \usepackage[round, authoryear]{natbib}. Now the problem is when I use that natbib with the provided package it throws me an error:

! Package natbib Error: Bibliography not compatible with author-year citations.(natbib)
Press <return> to continue in numerical citation style. See the natbib package
documentation for explanation.Type H <return> for immediate help....
    ...mand\NAT@force@numbers{}\NAT@force@numbers

This is what I used for the template:

\documentclass[cameraready]{cseminar}
\usepackage[round,authoryear]{natbib}
\lhead{CSE-E500 Seminar on Software Systems, Technologies and Security}
\rhead{Spring 2016}
\begin{document}
%==================================
\begin{abstract}
\vspace{3mm}
\noindent \textbf{KEYWORDS}: 

\end{abstract}
 %============================
\subsection{Related Study}

 \begin{figure}[h]
 \begin{center}
 \includegraphics[width=.5\textwidth]{figures/SCS}
 \caption{Source Conceptual Schema}
 \citep{lujan2004data}
\label{fig:SCS}
\end{center}
\end{figure}
% List of references is created with bibtex.
\bibliographystyle{plainnat}
\bibliography{technical-report}
\end{document}

The references file looks like this and I have 12 of those in technical-report.bib file:

 % 2009 ref year 
 @article{vassiliadis2009survey,
 title={A survey of Extract--transform--Load technology},
 author={Vassiliadis, Panos},
 journal={International Journal of Data Warehousing and Mining (IJDWM)},
 volume={5},
 number={3},
 pages={1--27},
 year={2009},
 publisher={IGI Global}
 }

But author year is mentioned already. Could you please help me out to fix this problem? Thanks in advance. In my paper, I am using two columns for each page.

8
  • you don't need [breaklinks] option for hyperref. that is set automatically. also breakurls is superfluous. hyperref does break URLs correctly.
    – naphaneal
    Apr 27 '16 at 14:27
  • Please tell us which bibliography style you use.
    – Mico
    Apr 27 '16 at 14:43
  • @Mico \bibliographystyle{plain}
    – bhordupur
    Apr 27 '16 at 15:04
  • Incidentally, the issue you describe is not related to either the hyperref or the breakurl package.
    – Mico
    Apr 27 '16 at 15:10
  • Where might one find a copy of the file cseminar.cls?
    – Mico
    Apr 27 '16 at 17:02
1

The bibliography style plain can only generate numeric-style citation call-outs.

Since you're using the natbib citation management package, you should (a) use the plainnat bibliography style, which can produce both numeric-style and authoryear-style citation call-outs, and (b) provide the option authoryear when loading the natbib package:

\usepackage[round,authoryear]{natbib}
\bibliographystyle{plainnat}

After making these changes, be sure to re-run LaTeX, BibTeX, and LaTeX twice more to fully propagate the effects of these changes.


Addendum: Here's an MWE:

enter image description here

\RequirePackage{filecontents}
\begin{filecontents}{biblio.bib}
@article{vassiliadis2009survey,
 title={A survey of {Extract}--transform--{Load} technology},
 author={Vassiliadis, Panos},
 journal={International Journal of Data Warehousing and Mining (IJDWM)},
 volume={5},
 number={3},
 pages={1--27},
 year={2009},
 publisher={IGI Global}
}
\end{filecontents}

\documentclass{article}
\usepackage[round,authoryear]{natbib}
\bibliographystyle{plainnat}

\begin{document}
\citep{vassiliadis2009survey}
\bibliography{biblio}
\end{document}
8
  • same error still.yes I did re-run using F6,F11 but no luck.
    – bhordupur
    Apr 27 '16 at 15:28
  • @bhordupur - You don't have more than one \bibliographystyle instruction, do you? And you don't load additional citation management packages (such as cite) either, right? Try deleting the aux and bbl files and then re-running LaTeX, BibTeX, and LaTeX twice more. If that still doesn't work, please post a complete code sample that generates the error.
    – Mico
    Apr 27 '16 at 15:34
  • I have exactly 12 different ref. in the paper. and only one bibliographystyle the one you suggested. I am gonna try it now again after deleting those files.thanks
    – bhordupur
    Apr 27 '16 at 15:50
  • this is error I get ! Package natbib Error: Bibliography not compatible with author-year citations.(natbib) Press <return> to continue in numerical citation style.See the natbib package documentation for explanation.Type H <return> for immediate help.... ...mand\NAT@force@numbers{}\NAT@force@numbers
    – bhordupur
    Apr 27 '16 at 16:18
  • 1
    @bhordupur I think it's best, you add a MWE to your question, so we can see what might cause the problem.
    – naphaneal
    Apr 27 '16 at 16:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.