4

My [magyar]{babel} and scrlayer-scrpage packages seem not to be working together… This is a minimum example:

\documentclass{article}

\usepackage[magyar]{babel}
\usepackage{scrlayer-scrpage}

\begin{document}

\section{Test document}

This is a test document.

\end{document}

The error I get here is:

E: .../Tester.tex:6 Illegal parameter number in definition of \reserved@b \begin{document}

Can someone help me figuring out what it means? Thank you in advance!

  • 1
    Welcome to TEX.SE! I know that magyar can cause problems. The solution described here seems to work also in your case. – campa Apr 29 '16 at 11:49
  • @campa might actually be a duplicate – clemens Apr 29 '16 at 11:58
3

It seems that

\makeatletter
\def\@@magyar@setup@psheadings{}
\makeatother

after loading babel solves the problem.

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}

\usepackage[markcase=noupper,automark]{scrlayer-scrpage}
\usepackage[magyar]{babel}
\makeatletter
\def\@@magyar@setup@psheadings{}
\makeatother

\begin{document}
\section{Test document}
This is a test document.
\end{document}

Note that I have used option automark for scrlayer-scrpage to get the section title in header.

Result:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.