4

I have an error with the following document, from my texlive 2016 and everything up to date, when I use lualatex

: You don't seem to be using either pdftex, luatex, or xetex.

\documentclass[oneside,a4paper, 12pt]{article}



\usepackage[T1]{fontenc} 
\usepackage{fontspec}
\setmainfont{TeX Gyre Termes}
\usepackage{polyglossia}
\setdefaultlanguage{english}

\usepackage{microtype}

\begin{document}
 challenge is to know whther s 

\end{document}

the text prints and I do not have the error with xelatex.

2
  • Welcome to TeX.SE. Note that the message you're getting is, strictly speaking, a warning message and not an error message. FWIW, I'm running TeXlive2016-pretest as well, and I obtain the same warning message that you do.
    – Mico
    Commented Apr 30, 2016 at 17:09
  • 2
    Btw tl 2016 is not released yet, so if you have problems with it you should report it on the text live mailing list. Thanks for testing and reporting btw
    – daleif
    Commented Apr 30, 2016 at 17:29

1 Answer 1

3

Load the luatex85 package:

\documentclass[oneside,a4paper, 12pt]{article}

\usepackage{luatex85}
\usepackage[T1]{fontenc}
\usepackage{fontspec}
\setmainfont{TeX Gyre Termes}
\usepackage{polyglossia}
\setdefaultlanguage{english}

\usepackage{microtype}

\begin{document}
 challenge is to know whther s

\end{document}

Then microtype will recognize luatex again:

  c:/texlive/2016/texmf-dist/tex/latex/microtype/microtype-luatex.def

(This should be needed only temporarly, microtype will certainly get adapted to the new luatex).

1
  • 2
    I guess with today's update oh microtype that should be soon in TL pretest, loading the luatex85 package might not be necessary anymore.
    – norbert
    Commented May 2, 2016 at 17:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .