10

When I type "tehnically" using WinEdt it will transform into "thenically", and show in pdf that way. Why is this and how to erase it?

  • 4
    This is almost certainly a feature of your text editor and not TeX/LaTeX itself. What editor are you using? Does it have an autocorrect mode (which would appear to be misconfigured)? – Loop Space May 2 '16 at 14:02
  • 1
    Which editor do you use? – Bernard May 2 '16 at 14:04
  • 3
    I don't use WinEdt, but when this happens to me, sometimes Ctrl-Z will undo the unwanted change. Assuming it is the "autocorrect" feature of WinEdt. This is not a bad question. – A Feldman May 2 '16 at 14:18
  • 2
    Why do you want to spell "tehnically"? Perhaps you might try "technically"? – Benjamin McKay May 2 '16 at 14:58
  • 2
    Four own votes is bizarre. I agree with @AFeldman that this is a reasonable question. – Andrew May 2 '16 at 15:02
10

This shouldn't happen. ‘teh’ is considered an active string because it often is a mistyping for ‘the’, and a macro defines auto-correction under special conditions. Check in your Options interface, on the right of the editor window, the contents of the file ActiveStrings.ini. It should contain exactly these lines:

STRING="teh"
  START_FILTER="~Alpha"
  END_FILTER="~Alpha"
  ENABLED=1
  MACRO="[BeginGroup;Backspace(2);Ins('he');EndGroup;]"

STRING="TEh"
  START_FILTER="~Alpha"
  END_FILTER="~Alpha"
  ENABLED=0
  MACRO="[BeginGroup;Backspace(2);Ins('he ');EndGroup;]"   

To modify the ActiveString.ini file (or any of the .ini files), open the Options interface in the left panel, select Active Strings to open it: enter image description here

There is a help icon, which directs you to the help for the current .ini file. Change the values to the correct ones, either by hand or by cut and paste. Once the file has been modified, validate the modifications by clicking on the leftmost icon (Load Current Script). If there's any syntax error, it will issue a warning. Otherwise, the modifications will be written to the script file that WinEdt reads on start, namely WinEdt.dnt (never write this one yourself!).

  • I guess the OP should change the contents of the file ActiveStrings.ini to match what was posted in order to fix the problem. Does the OP need to do this in an external editor, or can it be done through the WinEdt dialogue? Looks like a really nice editor, although sadly I assume this does not run on Wine. – A Feldman May 2 '16 at 14:43
  • It has to be done from within WinEdt, then validated clicking on the Load Current Script icon. What I don't understand is why the O.P. has this behaviour. Filters are defined to prevent it. – Bernard May 2 '16 at 14:47
  • I would guess data corruption of some kind. I don't understand the down votes, perhaps they are RTFM related. But: meta.tex.stackexchange.com/a/6508/90087 And as you point out, this is a strange problem, not an ordinary thing one might easily look up. Maybe add to your answer the "hold my hand" type of details to fix the problem by modifying the string definitions. – A Feldman May 2 '16 at 14:50
  • The link to meta above is, among other things, about RTFM etiquette. – A Feldman May 2 '16 at 15:02
  • 2
    @JyrkiLahtonen: Yes, I've just seen your post, and was going to answer when it was closed. I didn't even remember having answered for this problem! – Bernard Jan 10 '18 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.