3
\listfiles
\documentclass[12pt]{standalone}     
\usepackage{fontspec}

\begin{document}

test

\end{document}

creates

MiKTeX 2.9/tex/luatex/luaotfload/fontloader-2016-04-21.lua:353: attempt to call global 'getsubtype' (a nil value)

\endsa@boxit ... dvarwidth \color@endgroup \egroup

1.9 \end{document}

?

Any ideas what this could be? I cannot imagein that I am wrong typsetting this example?

  • 2
    The new luaotfload version (2.7) imho doesn't work with the luatex in miktex. So you need either get an older luaotfload (github.com/lualatex/luaotfload/releases) or try out miktex next: miktex.org/announcement/miktex-next-5900 (you will perhaps also have to update to luaotfload 2.7-fix-1, I don't know if it is already in miktex). – Ulrike Fischer May 2 '16 at 16:08
  • Your Luatex is too old, the getsubtype API has been around since version 0.85 whereas Luaotfload requires 0.95. – Philipp Gesang May 2 '16 at 19:38
  • Please provide a answer, so I can accept it. lua 0.8 is compatible with luafloat 2.5 – Peter Ebelsberger May 3 '16 at 15:20
  • I hit this page while searching for a solution where luaotfload claims that lualatex 1.0.0 is too old for it. I just upgraded MikTeX and learned that I have to install the recent version of luaotfload manually. See github.com/lualatex/luaotfload/issues/… – koppor Jan 5 '17 at 7:15
2

Try loading the luatex85 package as well:

\listfiles
\documentclass[12pt]{standalone}     
\usepackage{fontspec,luatex85}
\begin{document}
test
\end{document}

This works with MacTeX2016 / LuaTeX 0.95.0 / luaotfload 2016/04/21 v2.7. Without the luatex85 package, the MWE won't compile on this system.

  • I have executed the idea of ulrike fischer and reverted to the old version which is now working. If I use your code now, this code wont work but removing luatex85 will make it compileable. Strange... – Peter Ebelsberger May 29 '16 at 9:30
  • @PeterEbelsberger - luatex85 should definitely only be used with versions of luatex more recent than 0.80. If you have TeXLive2015, you mostly likely have luatex 0.80 and thus shouldn't have to load luatex85. – Mico May 29 '16 at 11:14
  • I have so many answers and it seems to me, that all are very helpful. I do not know which one I should accept as answer. I have reverted to old versions like Ulrike suggested....I will accept your answer, but as untested. Because I won't update now... – Peter Ebelsberger May 29 '16 at 12:52
1

When I was trying to solve this same problem I found some information that (as an inexperienced package user) was a little harder to decipher.

I started out by trying to use the \RequirePackage{luatex85} as described here After MiKTeX update when using LuaLaTeX: Package pgf Error: Driver file ``pgfsys-luatex.def'' not found but I then opted to try out the experimental miktex packages (enabled with the checkbox on the main screen of Update (Admin) for MikTeX as described and illustrated: http://miktex.org/kb/miktex-next). Then in order to ensure everything was successfully registered(?) I went to Settings (Admin) for MikTeX and on the "General" tab, I clicked RefreshFNDB. Then my luatex compiler started working again.

Of course this is a MikTeX oriented procedure that worked for me, but I will update the answer if and when I get this working on my linux machine as well.

  • Please see the comment in the answer above. – Peter Ebelsberger May 29 '16 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.