I'm working on mac.

  • I donwloaded the archive 1.8.23 from the SourceForge page
  • I extracted its contained files in my ~/.vim/ directory
  • I made the necessary changes (described in de vim latex manual) in my ~/.vimrc file (which I had to create because it did not exist yet)
  • I opened vim and typed :helptags ~/.vim/doc
  • I reopened vim and started editing an existing .tex file, but it seems vim latex-suite is not being loaded properly...

What am I doing wrong? I tried several things, including going into the ~/.vim/ directory, and used make, but I got the following errors :

rm -rf -- ./vim-latex-1.8.23-20100914-r
svn export -r HEAD . vim-latex-1.8.23-20100914-r
svn: '.' is not a working copy
make: *** [snapshot] Error 1

EDIT : My .vimrc file here.

  • I think we need more information. What exactly is in your .vimrc? What is the content of the .tex file you are trying to edit? Sep 14, 2010 at 21:48
  • 2
    What does :set ft? say on the LaTeX file. Vim uses some heuristics to determine if the file is a tex, latex, or context file, and if the file is short then vim may misidentify it as a plain tex file. :set ft? should say tex (and not plain_tex or context)
    – Aditya
    Sep 15, 2010 at 4:40
  • @Aditya : it says tex, which is understandable (see my attached .vimrc file) --- @Jal Hlavacek : In a few seconds, I'm attaching my .vimrc file, which is very simple the fact being it has been created for the purpose to use vim latex-suite.
    – Nigu
    Sep 15, 2010 at 7:18
  • @Jan Hlavacek : The content of my .tex file is a usual file which we can compile using several conventional editors such as texshop on my mac and other windows based ones for my colleagues.
    – Nigu
    Sep 15, 2010 at 7:28
  • @Nigu I created a git repository containing vim configuration for simplifying plugin management, and made it public in case someone else finds it useful: bitbucket.org/drozdyuk/vimfiles Mar 12, 2012 at 16:49

2 Answers 2


If I understand you correctly, you have tried make and not make install.

The Makefile is written such that make downloads the newest snapshot with SVN, and make install installs it. Try make install instead!

I would have written suggestion as a comment, but I do not have enough reputation.

  • Thanks, this worked! I had to do it in sudo mode to avoid all the permission clashes.
    – Nigu
    Sep 15, 2010 at 8:43
  • That's interesting! The installation instructions on the vim-latex's website do not mention running make at all. I don't remember if I used make when installing vim-latex manually, since the last time I did that was before Debian started packaging it, which was quite a while ago. Also, since you got permission clashes when running make install as a regular user, it seems that you actually installed vim-latex globally, rather than in your own .vim directory. I still think that just unpacking into ~/.vim should be sufficient, I am not sure what is going on here. Sep 16, 2010 at 2:26
  • @Jan: You are right, the make install installs globally (to $(DESTDIR) which is set to /usr/local/ on most systems). I also do not understand why unpacking into ~/.vim/ does not work. @Nigu: Can you post the output of :set runtimepath? ? It might help in debugging the problem. Sep 16, 2010 at 14:22

You can also try vim-addons install latex-suite in a shell.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .