0

I'm trying to generate arabic article with a new package arabluatex, which requires lualatex engine, writing simple "hello world" example

\documentclass{article}
\usepackage{arabluatex}
\newfontfamily\arabicfont[Script=Arabic,RawFeature={+ss05}]{Amiri}
\begin{document}
hello world
\end{document}

And compile my test3.tex file with lualatex

lualatex test3.tex 

Unfortunately the compilation do not succeed and stagnate for hours with this message

enter image description here

Note I have texlive 2015 on windows 10

  • Probably there is some font it doesn't like. check tex.stackexchange.com/a/140841/2388. – Ulrike Fischer May 3 '16 at 12:48
  • How can I find the font which cause the problem? – Salim Bou May 3 '16 at 13:12
  • Check the link. – Ulrike Fischer May 3 '16 at 13:23
  • Oh yes I run luaotfload-tool -v -vvv -u I find two font cmunssdc.otf and mingliub.ttc add the two file to luaotfload-blacklist and the problem is resolved thanks @UlrikeFischer. – Salim Bou May 3 '16 at 13:56
  • @salim bou: I doubt very much that cmunssdc.otf is broken in that respect as the CMU family has been tested with every version of Luaotfload for years. Perhaps you just keep a very buggy version of that font around? What version is it? – Philipp Gesang May 10 '16 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.