8

I'm working on Lubuntu linux. I need to create a 8-pages booklet, A5, saddle stitch. Firstly I created this document (a5-doc.tex)...

% a5-doc.tex
\documentclass[12pt]{article}
\usepackage[margin=20mm, a5paper]{geometry}
\usepackage{kantlipsum}
\usepackage{tgtermes}
\begin{document}
\kant
\kant
\end{document}

..then imposed the PDF (a5-doc.pdf) using bookletimposer. It produced an imposed PDF (a5-doc-conv.pdf), 4 spreads of A4-size with the following order: [8-1][2-7][6-3][4-5] (which is correct).

bookletimposer settings

bookletimposer

..and the results (as viewed on screen):

[8-1]

bookletimposer result, page 1

[2-7]

bookletimposer result, page 2

[6-3]

bookletimposer result, page 3

[4-5]

bookletimposer result, page 4

But when it came to print, the [2-7] and [4-5] spreads were flipped vertically in the wrong order.

Here's what it looks like..

flipped page in wrong order

Printer info: Laser printer with duplexer, installed using PPD driver.

Printing settings: layout: two-sided (long edge), paper size: A4, orientation: portrait, page scaling: none, auto rotate and center.

PS: When printing single double-side pages, it worked just fine.

I've tried short-edge as well, but didn't work. Do you think it's just a printer issue? I cannot test it using another printer or OS (since I don't have ones). Thank you.

imposed

UPDATE:

I tried this one (modified from here). It produced imposed spreads in the right order (just like bookletimposer did). But when printed (using same settings as above), the problem still persist.

\documentclass{article}
\usepackage[landscape,a4paper]{geometry}
\usepackage{pdfpages}
\begin{document}
\includepdf[pages={8,1,2,7,6,3,4,5},nup=2x1]{a5-doc.pdf}
\end{document}

UPDATE 2:

As @ignasi suggested, I tried this one.. and it worked. Although it looks weird on the screen, it's printed correctly. Thanks..

\documentclass[a4paper]{article}
\usepackage{pdfpages}
\begin{document}
% \includepdf[pages=-, nup=2x1, noautoscale, frame, signature*=8, landscape,  angle=180, delta=0 1cm]{a5-doc.pdf}
\includepdf[pages=-, nup=2x1, noautoscale, signature*=8, landscape, angle=180]{a5-doc.pdf}
\end{document}

Screen views:

Page 1

new imposed page 1

Page 2

new imposed page 2

Page 3

new imposed page 3

Page 4

new imposed page 4

Printed version:

update 2 (page 2 and 3)

update 2 spreads

btw. I'm a bit confused knowing this trick. It does look weird on the screen, but it works.

I've never had problem so far printing landscape imposed spreads. As long as they're in the right order, they'll be printed perfectly. Even if they're displayed as landscape in the viewer (as usual), they're printed just fine (just like what we see on the screen), no need to rotate the spreads orientation. I thought the printer will do it for us, not vice versa..

Anyway.. this trick has solved my problem. Thank you..

3

I finally solved the problem. Thanks to @ignasi for this tip.

% imposed.tex
\documentclass[a4paper]{article}
\usepackage{pdfpages}
\begin{document}
\includepdf[pages=-, nup=2x1, noautoscale, signature*=8, landscape, angle=180]{a5-doc.pdf}
\end{document}

a5-doc.pdf is a plain A5 file which contains the actual contents..

% a5-doc.tex
\documentclass[12pt]{article}
\usepackage[margin=20mm, a5paper]{geometry}
\usepackage{kantlipsum}
\usepackage{tgtermes}
\begin{document}
\kant % dummy text
\kant % another dummy text
\end{document}

The compiled PDF file looks weird on the screen (compared to bookletimposer's result, see my update screenshots above for details), but it's printed nicely.

PS: a few years ago before I met LaTeX, I used to create plain A5 document using word processor and imposed it using an acrobat plugin (I forgot the name). There were several options and settings for binding, including saddle stitch. Once it's done, there's an imposed PDF ready for print. It looks like bookletimposer's result above (landscape), but printed nicely without further tweaks.

0

Using my answer at Change location of increasing text length and adapting it to the current booklet problem, I create book.tex in a sequential way without regard to binding. Here is a sample 8 page book that prints its page number as the content of the page:

\documentclass{article}
\usepackage[paperwidth=.5\paperwidth,paperheight=.5\paperheight,margin=.5in]{geometry}
\usepackage{graphicx}
\newcommand\makebook[1]{\makebookhelp#1\relax}
\def\makebookhelp#1#2\relax{%
  \scalebox{15}{#1}\clearpage%
  \ifx\relax#2\else%
  \makebookhelp#2\relax\fi%
}
\begin{document}
\centering
\makebook{12345678}
\end{document}

When compiled in the normal fashion, it looks thus:

enter image description here

I chose a different page size here, but it is not necessary, as long as the aspect ratio is correct.

Then, I created a new document that processes book.pdf. The secondary tex document is

\documentclass{article}
\usepackage[paper=letterpaper,margin=0in]{geometry}
\usepackage{graphicx,ifthen,stackengine}
\newcounter{bookpage}
\fboxsep=-\fboxrule\relax
\newcommand\nullpage{\fbox{\rule{0pt}{1.5in}\rule{1.5in}{0pt}}}
\newcommand\showthepage[2]{%
  \protect\fbox{\protect\includegraphics%
    [width=.49999\paperwidth,height=.49999\paperheight,page=#1]{#2}}%
}
\parindent 0in
\setstackgap{S}{0pt}
\begin{document}
\Shortstack
{
\showthepage{8}{book}%
\showthepage{1}{book}
\showthepage{2}{book}%
\showthepage{7}{book} 
}
\clearpage
\Shortstack
{
\showthepage{6}{book}%
\showthepage{3}{book}
\showthepage{4}{book}%
\showthepage{5}{book} 
}
\end{document}

When it compiles, it produces this:

enter image description here

This new document can just be printed out in the normal way on a duplex printer to achieve the design the OP specified.

  • @guest_5758 I am glad Ignasi's suggestion worked for you. Nonetheless, if you would please let me know if the approach of my answer is on the right track or not, it will help me to decide whether to delete my answer or not. – Steven B. Segletes May 4 '16 at 0:18
  • @StevesB.Segletes Thanks. I do appreciate it. I have tried your approach. It works fine (as described above), but unfortunately doesn't solve my problem. I think you don't have to delete your answer. It's a part of learning curve.. – guest_5758 May 4 '16 at 0:37
0

I recently faced a similar issue. Using your first set up and the page ordering 8,1,2,7,6,3,4,5 it was enough to use print two-sided with short edge.

(I am sorry for posting this as an answer---not enough reputation to comment.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.