1

[edited to correct confusion over paths]

My Mac version of latex includes two versions of url.sty --- one is from 2006 and supports [lowtilde] while the other is from 1999 and does not:

$ grep 'ver ' /usr/local/texlive/2011/texmf/tex/latex/html/url.sty
% url.sty  ver 1.4    02-Mar-1999   Donald Arseneau   [email protected]
  \ProvidesPackage{url}[1999/03/02 \space ver 1.4 \space
% url.sty  ver 1.4   02-Mar-1999   Donald Arseneau   [email protected]
% characters.  The "\url" command will *never ever* hyphenate words.
% command follows whatever the currently-set style dictates.
% I.e., using whatever url-style has been selected.
% ver 1.1 6-Feb-1996: 
% ver 1.2 19-Oct-1996:
% ver 1.3 21-Jul-1997:
% ver 1.4 02-Mar-1999
$ grep 'ver '  /usr/local/texlive/2011/texmf-dist/tex/latex/url/url.sty
% url.sty  ver 3.3    12-Apr-2006   Donald Arseneau   [email protected]
 {url}[2006/04/12 \space ver 3.3 \space Verb mode for urls, etc.]
% url.sty  ver 3.3    12-Apr-2006   Donald Arseneau   [email protected]
% characters.  The "\url" command will *never ever* hyphenate words.
% command follows whatever the currently-set style dictates.
% I.e., using whatever "\urlstyle" and other settings are already in effect.
% ver 1.1 6-Feb-1996:
% ver 1.2 19-Oct-1996:
% ver 1.3 21-Jul-1997:
% ver 1.4 02-Mar-1999:
% ver 1.5 28-Mar-1999:
% ver 1.6 20-Jun-2002:
% ver 3.0 June 2003/Nov 2003:
% ver 3.1 Mar 2004:
% ver 3.2 June 2005:
% ver 3.3 April 2006:
$ 

Why are two versions installed and how to I specify the correct version?

7
  • 1
    TeX Live2011 and TeX Live2010 use version ver 3.3 (2006/04/12) of url.sty, and the lowtilde option can be used with this version. What exactly do you mean with "does not support"? Commented Oct 7, 2011 at 1:51
  • Ah. It seems that my Mac installation installes two url.sty files, one in texmf/tex/laytex/html/url.sty and one in texmf-dist/tex/latex/url/url.sty. The first is from 1999 and does not have the option. Why are there two and how do I get the proper one?
    – vy32
    Commented Oct 7, 2011 at 2:24
  • You should not have the one located in /texmf/tex/latex. I would suggest deleting it, and then rerunning texhash (or refreshing your filename database via tlmgr).
    – Werner
    Commented Oct 7, 2011 at 2:48
  • But that one was installed by the Mac PDF installer!!!
    – vy32
    Commented Oct 7, 2011 at 3:38
  • MacTeX doesn't install a tex/latex/html subdirectory under /usr/local/texlive/2011/texmf. So it must have been installed by some other program.
    – egreg
    Commented Oct 9, 2011 at 9:57

1 Answer 1

3

MacTeX doesn't install a tex/latex/html subdirectory under /usr/local/texlive/2011/texmf. So it must have been installed by some other program (probably some TeX to HTML converter you installed via a Makefile).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .