I am trying to make the Calibri font work in TexStudio.

Following several posts on here I included the command in the preamble:


And went into

Options -> Configure TexStudio -> Build -> Default Compiler -> LuaLatex

Which worked when I compiled, but it too upwards 40 seconds.

So another suggestion is to use XeLatex, so I did the same thing:

Options -> Configure TexStudio -> Build -> Default Compiler -> XeLatex

enter image description here

And received error:

enter image description here

Many users here said that using Xelatex to compile worked instantly, so I don't understand why it isn't working for me. Can anyone help?

  • Could you post a full compilable code? – Bernard May 3 '16 at 22:15
  • @Bernard Oh I see, there was a space in the file name. Something related to XeLatex not being able to process file with spaces in them tex.stackexchange.com/questions/238232/… Anyways this problem has been resolved ;-) – Rodrigo Amarante May 3 '16 at 22:31
  • 4
    I'm voting to close this question as its owner marked it as resolved. – yo' May 3 '16 at 22:40
  • 1
    Please post the solution in an answer below, don't edit the question. – Alenanno May 3 '16 at 22:47

Protip: Don't have file names with empty space in them such as

"Spider Man"


"Dolly Parton"

For whatever reason XeLatex compiler can't handle them.

Not the answer you're looking for? Browse other questions tagged or ask your own question.