0

I downloaded texlive 2015 from the Tex Users Group web and successfully installed. After installation I added these lines in my .bashrc:

PATH=/usr/local/texlive/2015/bin/x68_64-linux:$PATH; export PATH
MANPATH=/usr/local/texlive/2015/texmf-dist/doc/man:$MANPATH; export MANPATH
INFOPATH=/usr/local/texlive/2015/texmf-dist/doc/info:$INFOPATH; export INFOPATH  

However when I try to run it I get:

~$ latex
The program LaTeX is currently not installed. You can install it by typing:
sudo apt-get install texlive-latex-base

Same using latex --version.

This is a clean installation on a x64 Ubuntu 14.04 system. I have successfully installed latex 2013 (and previous versions) before in other machines just with ./install-tl and setting the PATH. Any idea what could be the problem?

Edit:

echo $PATH gives me:

/home/jaime/science/Ureka/variants/common/bin:/home/jaime/science/Ureka/bin:/home
/jaime/science/Ureka/python/bin:/usr/local/texlive/2015/bin/x68_64-linux:/usr
/local/texlive/2015/bin/x68_64-linux:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr
/bin:/sbin:/bin:/usr/games:/usr/local/games
  • Doesn't look like you've actually added it to the path: what does for example echo $PATH or command -v latex give? – Joseph Wright May 4 '16 at 18:26
  • I'll edit my question with the output from echo $PATH. No results for command -v latex – JVR May 4 '16 at 18:54
  • Case matters, you are exporting path in lower case. Also, move this to dot profile, log out and in again. It does not belong in bashrc (will give you headache later on). Btw: are you using standard Ubuntu, no switch to exotic shells? – daleif May 4 '16 at 18:59
  • 1
    As observed, you want x86_64 in those paths, not x68_64 – Joseph Wright May 4 '16 at 19:02
  • @JosephWright could have been days and I still would not see it. Thanks a lot! – JVR May 4 '16 at 19:09
0

I don't think your .bashrc is correct. Try reading this post here on how to do it.

In particular your PATH variable should be set like this:

PATH=$PATH:/usr/local/texlive/2015/bin/x86_64-linux

without the semicolon at the end. You also don't need to export.

I believe you have made a typo in your post. It should be x86_64-linux and not x68_64-linux as you have written!

After doing that, don't forget to open a new shell before you test if it worked.

  • I did as you suggested but same result. Also read the post and tried to do it in .profile but still same result – JVR May 4 '16 at 18:52
  • Yes, the x68_64-linux was the problem as other user also suggested. Thanks! – JVR May 4 '16 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.