0

I know this is a recurring theme, but any help is most welcome... I can't get rid of the white spacing. I think it getting generating by the "!" command in [!ht]. However is just not possible not using it because the thesis has many floats, and they everything gets REALLY mess up by removing the "!" command.

Any alternatives have just made things worst, like the FloatBarrier which brings even more white space.

Here is the code:

bla bla bla
\begin{figure}[!h] 

\captionsetup{width=0.45\textwidth}
\begin{minipage}{0.485\textwidth}  
\includegraphics[width=\linewidth]{path/235potm800pcm.pdf}    
\caption{Transitorio de potencia ante un SCRAM parcial, que inyecta -800 pcm en el sistema.}   
\label{24pcmU233_1}  
\end{minipage}  
%\hspace{\fill}  
\begin{minipage}{0.485\textwidth}
\includegraphics[width=\linewidth]{path/235ro10pcm.pdf}
\caption{Transitorio de reactividad para un SCRAM parcial, que inyecta -800 pcm en el sistema. La reactividad estacionaria se corresponde con $\rho_{drift}$.}
\end{minipage}
\vspace*{1cm} % (or whatever vertical separation you prefer)
\begin{minipage}{0.485\textwidth}
\includegraphics[width=\linewidth]{path/235Cm800pcm.pdf}
\caption{Cambio relativo en la población de precursores para un SCRAM parcial.}
\end{minipage}
%\hspace{\fill}
\begin{minipage}{0.485\textwidth}
\includegraphics[width=\linewidth]{path/235TNm800pcm.pdf}
\caption{Transitorio de temperatura para  un SCRAM parcial.}
\label{24pcmU233_2}
\end{minipage}
\centerin
\end{figure
bla bla

enter image description here

closed as off-topic by Jesse, Stefan Pinnow, Mensch, ienissei, John Kormylo May 7 '16 at 19:47

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • solved! it was the \vspace that for some reason insted of creating vspace between layers of pics just got stacked bottom. thx anyway – user105026 May 7 '16 at 17:20
  • 4
    I'm voting to close this question as off-topic because the OP has solved the problem. – Jesse May 7 '16 at 17:30
  • @Jesse I don't think that is a reason to close this question. Instead the OP should imho e.g. mark an answer as solved. IMHO its perfectly fine to answer the own question. – toogley May 7 '16 at 18:04
2

You have no paragraph separation (blank line) between your minipages so they are all on the same line within a paragraph, and only appear on different lines when the paragraph is later broken into lines in the usual way. If you use \vspace mid paragraph as here then the space is added after the paragraph is broken into lines and is added after the line on which the vspace was added.

So here it comes at the end, not between your minipages.

So always leave a blank line in your source before \vspace.

Also do not use [!h] it usually generates a warning and latex changes it to [!ht] to give itself a chance of setting the float but it is still very restrictive and likely to cause bad page breaks as it does not allow the figures to be put on a float page. use [htp]

Not the answer you're looking for? Browse other questions tagged or ask your own question.