1

This question already has an answer here:

I wonder whether there is anyone who is able to show the clock in a beamer presentation. I have not come across any working example. Following the tdclock documentation, I compiled the MWE below. It shows only blank boxes where the date and time are supposed to appear, see pdf attached. I would appreciate any advice.pdf output

\documentclass[xcolor=dvipsnames]{beamer}
\usepackage{beamerthemeshadow}

\usepackage[font=Helv,timeinterval=60]{tdclock}
\setbeamertemplate{headline}{\initclock\large{\tdyear-\tdmonth-\tdday
\quad\tdhours:\tdminutes}}

\usepackage{xcolor}

\title[]{Main Title}
\author[]{Zilore Mumba}
\institute[]{Unza}

\usepackage[font=Helv,timeinterval=60]{tdclock}
\setbeamertemplate{headline}{\initclock\large{\tdyear-\tdmonth-\tdday\quad\tdhours:\tdminutes}}

\usepackage{xkeyval}
\usepackage{hyperref}

\begin{document}
 \initclock

\title{Beamer Presentation}
\author{Zilore Mumba}

\begin{frame}
\titlepage
\end{frame}

\begin{frame}\frametitle{first slide}
content
\end{frame}

\end{document}

marked as duplicate by user36296, Zarko, egreg, Martin Schröder, user13907 Oct 14 '16 at 23:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    works fine for me. But you need the adobe reader as pdf viewer. – Ulrike Fischer May 8 '16 at 21:29
  • The operating system is also relevant: it works with Adobe Reader on Microsoft, but not on GNU/Linux. – Thérèse May 8 '16 at 22:00
  • It definitely works fine under Linux with Adobe Reader 9.5 as long as javascript is enabled – ArTourter May 8 '16 at 22:43
  • @ArTourter How does one do that? I don’t see any likely options under Preferences. – Thérèse May 9 '16 at 1:48
  • 1
    Make sure the package you got from your repository includes the javascript part. On the package from adobe it is in /opt/Adobe/Reader9/Reader/JavaScripts/JSByteCodeLin.bin. If this is not there is means your distribution removed it. I just moved it away and I get the same as the screenshots from the OP. – ArTourter May 9 '16 at 10:22

Browse other questions tagged or ask your own question.