1

I have a problem with compiling a subfile with bibliography entries in it. My setup is a follows:

My directory structure is:

main.tex/chap/chapter1/subfile.tex

Now, my main.tex has the following preamble:

\documentclass[12pt,a4paper,twoside,final]{memoir}
\usepackage{subfiles}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage[
backend=biber,
style=authoryear-icomp,
sorting=nyt
]{biblatex}
\addbibresource{bibliography.bib}
\begin{document}
\subfile{.chap/chapter1/subfile}
\printbibliography
\end{document}

Now, in my subfile.tex i have the following structure:

\documentclass[../../main.tex]{subfiles}
\begin{document}
a cited book \cite{Aigner2014}.
\printbibliography
\end{document}

When I compile my main file it works all fine and displays the references correctly, but when I try to compile the subfile, i get the following error message from Biber:

"INFO - This is Biber 1.9 INFO - Logfile is 'test.blg' INFO - Reading 'test.bcf' INFO - Found 1 citekey in bib section 0 INFO - Processing section 0 INFO - Looking for bibtex format file 'bibliography.bib' for section 0 ERROR - Cannot find 'bibliography.bib'! INFO - ERRORS: 1"

I can't seem to figure out why this is not working, since everything is apparently as it should be. I tried the solution provided here, but it still doesn't work. I don't know if it is just a problem with outdated versions of biblatex and biber or whether it is something else. I am really confused, since none of the solutions I have looked up here seem to work for me. I am working on windows 7, with my editor being Texmaker 4.5 and running Texlive 2014.

  • Is this now a duplicate of your other question? Or is there something more to it? (I notice that you deleted your earlier self-answer.) – moewe May 19 '16 at 6:04
  • That is true. I can undelete it if someone may come across this entry, but I don't think it will contribute that much. – Bartuc May 21 '16 at 11:59
  • Mhhh, currently we have a question here that is solved, but not marked as such, that is a bit unsatisfactory. So undeleting your answer would definitely improve the situation. – moewe May 24 '16 at 5:23
1

I solved it myself.

I totally forgot that I should specify my main.tex in my editor as the master-file, since then it compiles quite easily.

EDIT: It seems that this solution only makes it so that the mainfile can compile and include everything, because when I compile the smaller files, they will compile, but they can't display only their own content - they just show the mainfile's output and NOT their own. Any suggestion on what to try next?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.